8

In previous versions of Ubuntu, I used a calculator scope from some PPA. It was very nice, worked snappily and generally behaved like calc.

13.10 has it's own calculator, which can be used, but it stopped working after I disabled web results with unity tweak tool. Even when it was working, it was sluggish, as if it only used the calculator if it found nothing else anywhere.

I can still use the calculator by typing

calculator:1+1

or enabling it from the filter results -menu.

But those options defeat the purpose.

How do I enable the calculator scope to always be triggered by default?

  • This is for the probably default installed unity-scope-calculator. To enable it for the current user session, go to 'Filter Results ↓', and click 'Info' or 'Calculator'. A better way to disable online results, look in the Security/Privacy settings. There is this: askubuntu.com/questions/202944/… as well, which sort of means you might not be able to enable the calc as default... – Wilf Jan 15 '14 at 18:11
  • 4
    Just a little trick: you can type calc:1+1 instead of calculator:... it's faster to type and I can accept this. – WhiteWind Aug 13 '14 at 19:01
  • Also, you can go to the applications slide on the Dash and disable all extensions on the bottom (they are useless anyway) except the calculator. This way the remote calculation will return so fast that it become usable. You still need to be online for it though. – totymedli Oct 21 '15 at 4:39
3

When you perform a search on the home scope, there are a number of inputs that influence which scopes will be queried including:

  1. Scopes selected through the filters (either through "Categories" of scopes, or directly as "Sources").
  2. If the search term includes a keyword (e.g. your example of calculator:1+1).
  3. Recommendations from the smart scope server based on the search query (e.g. if the search term looks like an equation it recommends asking the calculator scope).

It is probably the third one that is enabling the scope usually, and that recommendation doesn't come through if you've disabled online results.

I don't think there is an alternative way to force it to be used unfortunately.

  • 3
    It's strange that the calculator scope would have anything to do with online result searching. I wish there was just a config file where I could specify this. – wizzor Jan 21 '14 at 8:59
3

This bugged me for ages, and I finally found a solution, buried here: https://bugs.launchpad.net/unity-scope-calculator/+bug/1440777

  • Install dconf-editor sudo apt install dconf-editor
  • Run it dconf-editor
  • Open com.canonical.unity.lenses
  • Add info-calculator.scope to the always-search list
  • Profit!
  • Thanks. Work. Is there a faster way to make calculations in Ubuntu? – Ambigus9 Apr 18 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.