When upgrading to the new kernel 3.8.0-35-generic (12.04 LTS) it doesn't create the initrd.img file and won't boot. I get a Kernel Panic because it's missing the img

I tried running

sudo update-initramfs -c -k 3.8.0-35-generic

but it does nothing. No image file is created

  • I couldn't get it to boot. I had to boot an older kernel and roll back. sudo apt-get remove 3.8.0-35-generic && sudo update-grub – Lance Badger Jan 15 '14 at 16:55
  • Maybe /boot is out of free space? – davidbaumann Jan 29 '14 at 23:50
  • Nope /boot partition has plenty of space. – Lance Badger Jan 31 '14 at 3:00

Boot an older kernel, then executed the following commands:

sudo apt-get purge linux-headers-3.8.0-35 linux-headers-3.8.0-35-generic linux-image-3.8.0-35-generic
sudo apt-get install linux-headers-3.8.0-35 linux-headers-3.8.0-35-generic linux-image-3.8.0-35-generic
  • Using the first line purges just fine to the older kernel and I can boot again, but as soon as I install using the second line breaks it again. I even tried to install a much newer kernel sudo apt-get install linux-headers-3.11.0-17 linux-headers-3.11.0-17-generic linux-image-3.11.0-17-generic and it still doesn't create the initrd.img-3.11.0-17 file. – Lance Badger Feb 25 '14 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.