1

After successful samba sharing already few days ago I have the same thing today yet I have received the following error:

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. 
The connection was refused. Maybe smbd is not running.

When trying to start/restart samba service I get the following

$ sudo service samba status
 * nmbd is running
 * smbd is not running
$ sudo service samba start
$ sudo service samba restart
$ sudo service samba status
 * nmbd is running
 * smbd is not running

My /var/log/samba/smbd.log

[2014/01/15 16:21:46,  0] smbd/server.c:1072(main)
  smbd version 3.6.18 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2011
[2014/01/15 16:21:46.426302,  0] smbd/server.c:1128(main)
  standard input is not a socket, assuming -D option
[2014/01/15 16:21:46.428538,  0] auth/auth_util.c:708(get_guest_info3)
  SamInfo3_for_guest: Unable to locate guest account [guest]!
[2014/01/15 16:21:46.428578,  0] smbd/server.c:1251(main)
  ERROR: failed to setup guest info.

My /etc/samba/smb.conf

$ grep -E "^[^#;].*" /etc/samba/smb.conf
[global]
   workgroup = WORKGROUP
   server string = %h server (Samba, Ubuntu)
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
        usershare allow guests = yes
        username map = /etc/samba/smbusers
        security = user
        guest ok = yes
        ; guest account = nobody
  usershare max shares = 100
  usershare owner only = False

3 Answers 3

1

The problem was with username. I have uncommented this line:

guest account = nobody

having nobody user in my system and now it works fine.

0

This error is also present in normal user sessions. I have it on 2 machines with fresh installs of Ubuntu 14.04.

I have filed a bug report https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1299186

Please mark the bug as "also affecting me" if you experience the same problems as apport will not trigger automatically when this bug occurs.

0

In order for usershare to work, smbd must also bind to the localhost, i.e.

interfaces = 192.168.0.100/8 eno1 127.0.0.1/8 lo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.