This is my first post so I hope I'm doing everything right.

I've been trying to fix this for a few days now with no joy. I installed Ubuntu 13.10 on my Revo 3700. Everything works with the Nouveau driver although of course I'm stuck on 800x600 and the gui is very jerky.

The Revo has an Ion chip which is reported in Ubuntu as GT218 [ION]. I went into software and updates and installed the Nvidia driver 319. Rebooted and got a blank screen with a blinking cursor after the splash.

Since then I've booted into recovery mode about 1million times and tried all sorts: installing Nvidia driver 304 from software and updates installing Nvidia driver 319 using the .run file from the nvidia site installed using sudo apt-get install nvidia-current and blacklisted nouveau myself

All of these have the same result which makes me think I'm missing something fundamental. I keep having to reboot and delete my xorg.conf file to get back to nouveau which is very time consuming.

One perhaps important detail is that I'm doing this from the hdmi port on the revo as this is the only display I have to use at home. Everything appears on here though including a blinking cursor so I figured it's ok?

Does anyone have any other fixes I can try?

Edit: I tried all suggested to no avail. At the weekend I'll try the new nvidia drivers that have come out since I asked

  • I've basically tried everything there that's relevant. There's a couple of things I could potentially try a little differently when I'm back with my computer. I was hoping someone might have the same hardware and software as me and therefore the same issue and a solution. Probably wishful thinking :) – user844621 Jan 15 '14 at 18:12
  • Thanks karel. I think the only bit from there I haven't tried is the sudo apt-get install linux-headers-$(uname -r). I don't really understand what that's supposed to fix? Not overly reassuring that thread was from 2011 and hasn't been solved yet! – user844621 Jan 16 '14 at 18:05
  • When you are using the Nvidia drivers, post the contents of /var/log/Xorg.0.log. Also, you sure the nouveau doesn't support the card? – Braiam Jan 22 '14 at 19:50
  • I nominate this for reopen: 1. The answers in the duplicate one didn't help the OP. 2. The dupe question is about a different version of the ION's. 3. Some of the upvoted answers in the duplicate one are plainly wrong. (those which says that ION is switchable graphics, aka. dual VGA cards) 4. And that question is for 10.04 this is for 13.10, possibly different problem. 5. And that question isn't solved either. – falconer Jan 22 '14 at 21:56
  • @user844621 I have an ION based nettop (though a different version of the IONs) and it runs 12.04 without problems with the nvidia driver. The only thing I had to change in it is to add the vga=normal nomodeset kernel parameters to GRUB. Please try to set these parameters and see if it helps. If you don't know how to add kernel parameters here is a Q&A showing it to you. – falconer Jan 23 '14 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.