Today after regular system updates on my 12.04 LTS system, I cannot login anymore. On a greeter password is said to be invalid immediately (without the usual delay). And on tty the same result, just delay is present

This is what I already tried:

  1. Checking Caps lock, Keyboard layout and similar things.
  2. Going into recovery mode root shell, remounting filesystem passwd`ing
  3. updating system from apt-get and root shell
  4. chroot`ing into my system from liveUSB, and executing passwd

A little more about passwd, I wanted to change/update my password with passwd on root shell (recovery mode), and from chroot`ed environment (from liveUSB). But I could not do so, because I always got an error:

my-computer-name# passwd myUserName
passwd: Authentication token manipulation error
passwd: Password unchanged

The filesystem has been remounted to rw correctly, (I tried to create/edit/save some files with vim).

In the file /var/log/auth.log I can see one strange message emitted from lightdm, that seems to be related to this issue:

pam_winbind(lightdm:auth): request wbcLogonUser failed: WBC_ERR_AUTH_ERROR, PAM error: PAM_USER_UNKNOWN (10), NTSTATUS:NT_STATUS_NO_SUCH_USER, Error message was: No such user
pam_succeed_if(lightdm:auth): requirement "user indgroup nopasswdlogin" not met by user "rytis"

These are the packets, that has been updated by update:



Long time ago I set root password for my computer, and while I cannot log into root with that password while booting normaly, I can, however, while booting into recovery.

  • Booting from a live CD/DVD/USB and resetting your password from a chroot may work. So this might be a duplicate of How do I reset a lost password (using recovery mode requires me to type the password)? even though the point of failure is different. I recommend trying that, then if it doesn't work, editing your question to explain what happened. (Even if this is closed, your edit will prompt it automatically to be considered for reopening.) Does login on a virtual console work? – Eliah Kagan Jan 15 '14 at 9:31
  • Unfortunately, no luck... I tried chroot`ing from live system, and passwd gave the same error as in recovery terminal – Rytis Karpuška Jan 15 '14 at 10:18
  • What if you manually change the hash in the shadow password file? I recommend backing up the shadow file before editing it with nano (or whatever other editor you prefer). One way to back it up, once you're in a root shell, is cp /etc/shadow /etc/shadow.old. – Eliah Kagan Jan 15 '14 at 10:42
  • mmm... still no luck... In the /etc/shadow password I copied password (hash part) of user root (and its password works while in recovery mode), to my user password hash part, but passwd is still not working, and I still cannot login into my system... :( I`m continuing to look for solution – Rytis Karpuška Jan 15 '14 at 11:00
  • @user207934 "I copied password (hash part) of user root (and its password works while in recovery mode)" What do you mean when you say the root's password works in recovery? Did you set a password for root? (Ubuntu normally have no password for root) And how do you know it works in recovery? When you boot up recovery you gain root access without typing any password. – falconer Jan 15 '14 at 11:51

Ok Finally I got it solved:

I just reinstalled all the packages which was related to the PAM, I do not know which one exactly was causing the problems:

sudo apt-get install --reinstall libpam-cap libpam-ck-connector libpam-cracklib libpam-gnome-keyring libpam-modules libpam-modules-bin libpam-winbind libpam0g

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.