I have a newish 12.04 box that I converted from FreeNAS due to the difficulty with the FreeNAS operating system and slow transfer speeds over gigabit ethernet. I got 12.04 setup without many difficulties and have been using the software RAID 5 for an array of 4 1 tb disks. Average read rate on the array is 298 MBps. Setup NFS to connect between the Linux server and my Mac and was initially getting transfer speeds between 80 MBps and 110 MBps. Something has changed and now I am getting peak transfer speeds of 25 MBps with an average of around 17.5 MBps.

I've checked with a Windows 8.1 machine and with a Mac, with both Samba and NFS, and the transfer speeds are almost exactly the same across the board. Ran several tests with iperf, all of which have shown consistent speeds of 950 mbps so it would seem to be a software issue as opposed to a limit imposed by the hardware. I have downloaded Bonnie++ but I honestly have no idea where to begin with getting that to output something that is intelligible to me. All of my hardware is the same as when I was getting better performance so I am assuming it is something on the software side of Linux.

In Linux, /etc/exports is setup for the NFS server as:

/fileserver *(rw,async,no_subtree_check)

On the Mac it is set to automount to /Network/Filserver with the following settings:


I had rsize and wsize set to 8192 but took it out as I figured it might do a better job negotiating those settings automatically.

Here's the information returned on the network card:

    sudo lshw -class network
        description: Ethernet interface
        product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        vendor: Realtek Semiconductor Co., Ltd.
        physical id: 0
        bus info: pci@0000:02:00.0
        logical name: eth0
        version: 06
        serial: d4:3d:7e:d8:0f:47
        size: 1Gbit/s
        capacity: 1Gbit/s
        width: 64 bits
        clock: 33MHz
        capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
        configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip= latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
        resources: irq:40 ioport:d000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

Router is a WNDR3700, all Cat 5e cabling with a gigabit swtich. I have tried different ports on the switch and the router and all comes back the same.

Any help would be appreciated. I have intermediate Linux and networking skills but I am by no means an expert on either one. Thanks!

  • A couple other notes - I just checked and writes are going to the server around 110 MBps so it is only the reads that are slow going. Also, I have full duplex & 1000mbps set on the NICs. – Andy Warren Jan 15 '14 at 1:58

You could look through your logs (the slash key ("/") will do a case-sensitive search):

cd /var/logs
less syslog
less messages
less dmesg

...or watch new entries to them:

grep -i error /var/logs/syslog

I think you might be asking for a network troubleshooting tool like Wireshark or info troubleshooting NetworkManager.

However, the slow transfer speeds over the network may only be a symptom of issues reading/writing to disk. Try looking at Disk Utility or running some commands:

sudo badblocks -sv /dev/desired/path
sudo fsck /dev/desired/path

Can you remember any changes at all from when it transfered at higher rates, to when it transfered at lower rates?

  • There have been a couple of additional systems that have gone on and off the network but other than that there have been no changes. I have checked and repaired the array through Disk Utility but that didn't do much to help the issue. Every once in a while I will start a transfer and the speed will spike to ~110 MBps but then drop back down to ~17.5 MBps after a few seconds. That, coupled with the fact that I can write to the array faster than I can read from it makes me think it is an issue with the array but aside from Disk Utility I'm not sure how to go about diagnosing the issue – Andy Warren Jan 15 '14 at 3:56
  • I wasn't familiar with the "badblocks" command so that is running now but will take a while to finish. I ran fsck last night but it came back as clean. I might try again tonight to see if I get a different result – Andy Warren Jan 15 '14 at 4:00
  • did the logs show any indicators? – conman253 Jan 15 '14 at 4:39
  • There are sever SMART Prefailure Attribute flags in there but from what I have read that seems to be alright as long as the SMART test comes back clear. Other than that everything looks as I would expect. At this point I am resyncing the RAID to see if that helps resolve any issues. Ran fsck again and it came back clean. – Andy Warren Jan 15 '14 at 5:49
  • Resync of the RAID did not yield any results. Ran hdparm and dd to check drive speed and all came back at 380+ MBps for reads. I'm going to try booting from the LiveCD tonight to see if the problem persists. – Andy Warren Jan 15 '14 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.