My wireless connection is extremely slow. I am using Ubuntu 13.10, but has been persistent with previous releases as well. http://paste.ubuntu.com/6741980/ http://paste.ubuntu.com/6753596/

  • 1
    The marked dupe is for the driver iwlwifi; this questioner has rt2800pci. The suggested fix will be ineffective. – chili555 Nov 17 '15 at 15:55

Check if you have power management off using:


If you have power management on, disable it (temporarily) using:

sudo iwconfig wlan0 power off

This worked for me (I have a D-Link DWL-G122 adapter).

If you want disable persistently power management you should have /etc/rc.local like this:

#!/bin/sh -e
# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.
sleep 10
iwconfig wlan0 power off
exit 0

Here you can add the commands that you want run at startup, but the last row must be always exit 0


I suggest you try a driver parameter:

sudo modprobe -r rt2800pci
sudo modprobe rt2800pci nohwcrypt=Y

Also, explicitly set your regulatory domain from here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 For example, if your code is FR, then do:

sudo iw reg set FR

I also suggest you experimentally turn off wireless N at the router. When we discover the setting(s) that fix the wireless, we'll tweak a few files and make it persistent.

If the problem persists, let's install a backported driver. Please get a temporary wired ethernet connection. Download this file to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.13-rc2/backports-3.13-rc2-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

sudo apt-get install build-essential linux-headers-generic
cd ~/Desktop/backports-3.13-rc2-1
make defconfig-wifi
sudo make install

'make' takes a few minutes; please be patient. Reboot and let us have your report.

  • The commands, in order, turned off network and wireless. I set regulatory domain. Apparently my ATT router only has b/g. – user233824 Jan 15 '14 at 1:44
  • Didn't wireless come back at: sudo modprobe rt2800pci nohwcrypt=Y ?? – chili555 Jan 15 '14 at 1:50
  • Yes. Sorry. I didn't give it enough time. Message came up as "you are now offline", but when I waited, it did come back on. – user233824 Jan 15 '14 at 1:55
  • And is it faster, slower or the same? – chili555 Jan 15 '14 at 1:59
  • The same (.32M download on wireless, 20.0M + when plugged in). – user233824 Jan 15 '14 at 2:04

Not sure if you ever solved this but I had to disable power management on the card using

sudo iwconfig wlan0 power off

and the wifi began running at full speed on this laptop. This was on Ubuntu 16.04.


Turning power management off solved it for me on Ubuntu 16.04 as well.

However, I would have to run sudo iwconfig wlan0 power off every time I connect to a network.

For that, I have illustrated a solution at https://askubuntu.com/a/825976/349291

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.