I can't get my desktop out of suspend through WOL. Running Ubuntu 13.10, installed the RTL8168 driver from the Realtek site (was provided by Realtek site for onboard RTL8111E on mobo Asrock b75-pro3-m)

Using ethtool, I set the onboard NIC to wake on "g" (magic packet). In the BIOS, I set wake on "ring", "PCI devices" and "RTC" (set to OS), I also disabled "deep sleep". Yet, the LED's of the onboard NIC are NOT lighting up when in suspend, although I've read on this forum that this isn't necessarily a requirement for the NIC to listen to WOL.

I tried sending magic packets to the MAC address of the onboard NIC through several UDP ports: 7,9, 2304 and 655325 ... alas with no effect. I tried some quirks for pm-suspend, but that did not help either.

I'm sending the magic packets through my laptop (wireless), which is running Windows 7 (using softwares such as mc-wol and wake-on-lan from aquila software).

-update: viewing cat /proc/acpi/wakeup I noticed that the ethernet interfaces did not have the status "enabled". So using echo xxxx > /proc/acpi/wakeup I changed this, but still no effect.

Perhaps important information: I also have a Realtek PCI NIC of type RTL8169, for which I also installed the RTL8169 driver provided by the Realtek site.

Update: Setting NETDOWN = NO in /etc/init.d/halt didn't help either

Update: No results from echo on > /sys/class/net/$interface/device/power/control echo enabled > /sys/class/net/$interface/device/power/wakeup

Blacklisting the r8169 driver only caused my r8169 NIC to get disabled: editing /etc/modprobe.d/blacklist.conf and adding #blacklist r8169 driver blacklist r8169 So that didn't do it either...

I'm not sure what else I can do to resolve this. Any thoughts ?

Many thanks in advance :-) !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.