I've tried everything I could find on the Internet, but still can't download anything from the Ubuntu Software Center.

It won't install anything and it won't do any progress when downloading. I have even tried reinstalling Ubuntu.

When I try to download anything, it says "updating cache".

By the way, I'm using 13.04, and it says I have Internet, but the Internet won't work, I also used the b34 or 43 method.

Here is the outcome when I typed software-center in the terminal: http://paste.ubuntu.com/6791762/

2014-01-21 15:11:07,927 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2014-01-21 15:11:10,001 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2014-01-21 15:11:10,316 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2014-01-21 15:11:10,348 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2014-01-21 15:11:10,367 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2014-01-21 15:11:10,367 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2014-01-21 15:11:10,449 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2014-01-21 15:11:10,646 - softwarecenter.backend.spawn_helper - WARNING - exit code 1 from helper for '['/usr/share/software-center/piston_generic_helper.py', '--datadir', '/usr/share/software-center/', 'RatingsAndReviewsAPI', 'review_stats']'
2014-01-21 15:11:10,646 - softwarecenter.backend.spawn_helper - WARNING - got error from helper: 'WARNING:__main__:connecting to http://reviews.ubuntu.com/reviews/api/1.0/review-stats/any/any/: No such file or directory
  • 1
    Run software-center from a terminal and add the output here. This is still however likely a bug.
    – kiri
    Jan 14, 2014 at 21:57
  • Heres an image for how it looks like, since the output was too long: mediafire.com/view/myfiles/#omyiwasbbtm5no2
    – user235747
    Jan 15, 2014 at 14:12
  • Actually we prefer the output here even if it's long.
    – Braiam
    Jan 16, 2014 at 16:39
  • But it's too long to put it here.
    – user235747
    Jan 17, 2014 at 16:37
  • @user235747 Please use a text paste site such as paste.ubuntu.com. Then provide the URL here, preferably by editing your question. (This will make it easier for people to immediately figure out what the issue is in your question, automatically get your question reviewed for opening, and draw attention to your question which could lead to someone seeing it who knows the answer.) Thanks! Jan 18, 2014 at 9:08

1 Answer 1


Let's say you want to install SubDownloader an app to download/upload movie subtitles.
Open up your software center and open the subdownloader page. You can search for it then click more details. Check image below:

enter image description here

Don't click the install button but scroll down till you see the version name and number. It's usually between 'People also installed' and 'reviews' sections. Copy the name of the app without the version number - in this case, copy just subdownloader.

Go to your terminal and type sudo apt-get install subdownloader Though now you'll replace the word 'subdownloader' with the one you copied earlier and press enter.

In case of any error messages, paste them and provide us the link.

  • paste.ubuntu.com/6949150
    – user235747
    Feb 17, 2014 at 14:55
  • Which package are you trying to install?
    – Parto
    Feb 17, 2014 at 18:07
  • I'm trying to install MonoDevelop
    – user235747
    Feb 20, 2014 at 5:18
  • Run sudo apt-get update && sudo apt-get upgrade then sudo apt-get install monodevelop In case of any errors, edit your question and include them.
    – Parto
    Feb 20, 2014 at 6:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.