0

I have looked at other answers on the web and on this site, but most of them seem to be for people who want to use Samba without a password. We have a mostly Windows 7 network. We set up Samba on our Ubuntu Server machine. Here are the relevant parts of the config file:

workgroup = our.windows.domain
security = user
[sharename]
comment = my share
path = /home/myuser
browsable = yes
guest ok = no
read only = no
create mask = 0755

After making these changes to the config file and trying to connect the first time, I got in without a password. Anyone on our local network can mount the share \1.2.3.4\sharename without being asked for a password. I want it to ask me for the Linux username and password. What step have I missed? Is there any other info you need to help me?

Thanks in advance!

Jeremy

1

By default, Windows will supply the local user's credentials when connecting to a network share. You have configured a Windows domain, so presumably users would use the same credentials to log on to their workstations and to connect to the Samba share. Thus the above behavior on a Windows client is normal.

| improve this answer | |
  • I think you're right, so I followed up with a test. I tried the valid users setting and added myself. I could get in without a password. I removed myself from that and added a different user (not my logged-in Windows user) and I was asked for a password. My credentials didn't work, but the other user's credentials did. So, I'm just waiting for someone else in the office here to try to connect to my share. I think since I have listed myself as the only valid user, no one else will be able to get in. I'll post the results here as soon as possible! – mrcoulson Jan 14 '14 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.