I tried to grow the ext4 partition by shrinking sda4 and then adding the unallocated partition to the ext4 partition, where Ubuntu lives.

The selected partition, sda6 (see image), contains the bios_grub so I need to move that one. GPartEd however, won't let me.

I have "boot repair disk" on a DVD, so I figured if I just 'simply delete' sda6, assign the unallocated space to the ext4 partition and then booting into "boot repair disk" would make everything work like it should.

image description

I need some help in this, because I need the extra space. Nothing has been done yet, I'm at the point the above image depicts.

1 Answer 1

  • Simply delete /dev/sda6.

  • Then right-click on the dev/sda7 ext4 partition to add the unallocated space 97.71 GB+1 MB to the ext4 partition.

  • Finally ran boot-repair.

Note: Please make sure that the partitions which you are going to resize should be unmounted.

  • I had a similar problem. This answer worked for me. Jan 5, 2016 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.