2

My computer shut down fine until I decided to install the Clementine music player. Now when I go to shut it down it first closes the Clementine window, and I have to go to the shut-down dialogue again. It does this about half the time, sometimes it shuts down immediately as it should.

Are there any shut down configs in the Gconf or Dconf editors that would solve this?

Its not a major issue, but still an annoyance.

  • 1
    This is not limited to Clementine... Steam does this as well, I noticed it on another program yesterday as well but don't remember now which it was.... (not sure why either, which is why this is just an informative(maybe) comment) – TrailRider Jan 14 '14 at 3:39
  • I've had this happen with chrome of firefox under kubuntu as well (but it's not consistent) – virtualxtc Jan 14 '14 at 3:57
  • Its reassuring to know I'm not the only one having this problem. It only started to happen after I installed Clementine. – Weylin Schreck Jan 14 '14 at 4:01
  • Your not the only one and I would assume that it only started after installing Clementine because it is one of the few programs that behave this way.....I've never had an issue with Firefox(don't use Chrome), but I use Ubuntu, not KDE. The behavior that I notice is consistent, but only with the few programs.... – TrailRider Jan 14 '14 at 4:31
  • I've only had this problem with the Clementine window open. Never with firefox, GIMP, Audacity, Audacious, Rhythmbox, Banshee. Those are the only programs I would have open upon shutting down. – Weylin Schreck Jan 14 '14 at 4:51
0

A system update or Clementine upgrade might fix the problem. From terminal try:

sudo apt-get update
sudo apt-get upgrade clementine

It's good practice to exit out of applications before powering off; I'd try that too. Next, you could try shutting down from terminal (what I do everytime with Ubuntu Server 12.04):

sudo poweroff now

Add the -f option to force it if that doesn't work. There's also a --verbose option that will help identify the problem. Lastly, you can kill the process(es).

  • this issue is not as dire as needing to force a shutdown or kill processes. It's just that some programs, when opened will shut down when you click the shutdown dialog but the system will not shut down...when you open the shut down dialog the 2nd time the system shuts down normally, or if you close the Window in question first the shutdown works normally. I would assume it is an issue(bug?) with just a few selected programs and the way they interact(or don't) with the shutdown process.... – TrailRider Jan 14 '14 at 4:28
  • I haven't updated the repositories since I installed clementine. I will try and see if that works. Also I agree with TrailRider; it is not such a dire issue that would require me to force a shutdown. I may however when I am bored choose to run the verbose shutdown option a number of times to see if it happens with the terminal shutdown command. – Weylin Schreck Jan 14 '14 at 4:48
  • 1
    If no one can figure it out, here are some links to help report a bug: Official Documentation; Forum Discussion. – conman253 Jan 14 '14 at 19:40
  • I'll report it in a day or two, gonna see if anyone comes up with an answer after I bounty it. – Weylin Schreck Jan 15 '14 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.