15

So, I managed to dual boot Windows 8.1 and Ubuntu 13.04. In Ubuntu 13.04, I installed the drivers for my graphics card(AMD HD Radeon 7700 Series, I'm pretty sure it's a 7790 one and Intel HD Graphics 4600 for Motherboard, but this shouldn't be necessary, considering that it's not the motherboard where I have connected the HDMI) for HDMI. I went to System Settings, and then to Sound, selected the HDMI sound option. Now, whenever I play anything that has sound, the audio has static and crackling. It does not play correctly. I tried searching, but all I find is questions in which the HDMI audio is simply not recognized and not playing.

  • Do you have HDMI audio set for Windows as well? Is the HDMI cable you're using connected to your GPU or motherboard? There is a good chance you are picking up on interference from your motherboard, which causes the crackling. I have a similar problem myself, and have to route my audio through my keyboard to prevent it. – Dillmo Jan 14 '14 at 0:53
  • I do have HDMI audio for Windows as well, and there are no such problems. And the HDMI cable is connected to the GPU. – TehSephirothSpirit Jan 14 '14 at 0:55
23

SOLUTION:

I finally found a solution to my problem randomly.

sudo pico /etc/pulse/default.pa

look for

load-module module-udev-detect

and add tsched=0

load-module module-udev-detect tsched=0

This simple modification fixed all the sound crackling and static on my PC, in Google Chrome, chromium, HTML5 videos, etc etc

  • I did this, and after a reboot, the static was gone and the crackling was reduced a lot. Now using HDMI is actually enjoyable. Thanks a lot. I do hope this will work with 14.04 when I upgrade(It should work, logically. And I'm going to wait for drivers specifically for 14.04 before upgrading, so we could at least be sure that drivers are not at fault(?)). – TehSephirothSpirit Apr 8 '14 at 16:51
  • This fixed it for me, too! Can you tell us what this has changed? I'm curious if this may affect something that will give me trouble later on. – Gilgamesh Apr 17 '14 at 21:04
  • 4
    It turns off time based audio scheduling. Apparently some people have glitches with it turned on and for others it works better when turned off :/ – TehSephirothSpirit Apr 21 '14 at 21:46
  • This resolve the noisy and crackle hdmi sound with a radeon x290, thank you. – Le Gluon du Net Mar 1 '15 at 13:56
  • Unfortunately this fix does not work in 16.10 – Jack Dec 26 '16 at 23:52
6

I have a ATI R7 260x, the HDMI audio problem was solved when I've had trying two different workarounds together. It's working as designed now. (on Ubuntu 14.10 64-bit)

Follow the steps below:

  1. Open the terminal with Ctrl+Alt+t.

  2. sudo nano /etc/pulse/default.pa

  3. Replace the line

    load-module module-udev-detect
    

    with

    load-module module-udev-detect tsched=0
    

    and save file.

  4. sudo nano /etc/modprobe.d/alsa-base.conf

  5. Insert options snd-hda-intel vid=8086 pid=8ca0 snoop=0 at the end of the file.

  6. Reboot the PC

  • Now the sound is perfect, thanks. My video card is also a R7 260x – Thomio Apr 16 '15 at 21:30
  • This fixed the static issue for my onboard Intel audio device in Ubuntu 14.04. Thanks! – randlet May 12 '15 at 14:41
1

I've had crackling and static as well and I solved it by first muting microphone input, and secondly changing my sound to 7.1 surround (even though I only have 2 speakers).

  • Well, I don't have any microphone, and I don't have an option to change HDMI to 7.1 surround. I can do that with the other ones, though. But then I won't have sound at all. – TehSephirothSpirit Jan 14 '14 at 3:26
0

In case others run into this issue, I've had this come up when installing pipelight on Ubuntu 14.04 with the AMD Catalyst 14.6 drivers using an A10-7800 APU.

My only solution was to remove pipelight, but I had not run into the solution above. It's quite possible pipelight messes something up that this solution fixes.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.