I have a HP Pavilion laptop with an NVIDIA GPU. With each major upgrade of the Ubuntu OS I've had a battle getting the nvidia driver to behave, but each time I have managed it. A while ago I updated to 13.10, went through the usual dance, and got it working. A few days ago, however, I did a minor software update and now the graphics driver is completely hosed. After much fiddling its now got to the point where I'm completely stumped as to how to proceed. The repeatable sequence I can do is:

  1. boot into kernel 3.11.0-15-generic
  2. when it tries to boot X, the nvidia splash screen fails with lots of picture noise
  3. A primitive dialog pops up to say that the system is running in low graphics mode. None of the options presented in that and subsequent dialogs seem to help.
  4. I Ctl-Alt-F1 into the console and check that:

    sudo apt-get install nvidia-331

which seems to be the latest driver from nvidia.

I select it using:

sudo jockey-text -l
sudo jokey-text -e kmod:nvidia-331

Which runs fine. This doesn't load the module in however, so I force it:

sudo lsmod | grep nvidia
sudo modprobe nvidia_331
sudo lsmod | grep nvidia

and the last lsmod now shows the module is loaded with 0 users of it.

Then I run:

sudo /etc/init.d/lightdm start

This time X comes up with the nvidia splash screen, and then finally the usual ubuntu login screen. Logging into that does bring up my desktop, but without any of the unity trappings such as the icons in the left or the bar on the top or any display manager. A "System program problem detected" dialog pops up, but gives me no details as to what it actually is.

Then when I reboot, it's back to square one where the nvidia driver needs to be reset in jockey and modprobe'ed again - it's not retaining that information.

Clearly nvidia drivers are fragile at the best of times, but any help from people who might have been through this same pain would be greatly appreciated.

  • I had same problem, with Nvidia NVS-310 card. Minor update to 13.10, and mostly downhill from there. I have two PCs, nearly identical, and have since rebuilt both (new 13.10 installs) with no further issues. Did have glitch with RAM (on one PC), that would only sometimes occur, which may have contributed. However, by that stage I had made things worse (installing 331, from 2 different PPA's). Hope that is helpful. – david6 Jan 15 '14 at 7:45
  • I Read here that nvidia-304, nvidia-319 is not working in ubuntu 13.10. You have to install nvidia-331 for ubuntu 13.10. Is that true? – Jasleen Kaur Jun 8 '14 at 10:12

had a sort of similar issue.

  • I am using ubuntu-x-swat ppa (ppa:ubuntu-x-swat/x-updates)
  • after update to nividia_331, nvidia was not loading on boot
  • using sudo modprobe nvidia_331, and then sudo service lightdm start would get everything working (get me into the GUI)
  • adding nvidia_331 to /etc/modules solved this, but I am not sure if that is the proper way to do it or not
| improve this answer | |

For Nvidia + Intel hybrid laptops (uninstall any other driver first) use the following command :

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime
| improve this answer | |
  • Thanks for your suggestion. However I'm afraid it didn't work. I uninstalled all the nvidia driver pacckages I could find, run your selected ones, re-ran jockey-text to select it and re-booted. Server still failed. Modprobe'ed to get it install nvidia-319-updates, and now the X server doesn't start up at all - no nvidia splash screen. Do I have to install ubuntu from scratch to fix this problem, or is there a serious problem with this version of the kernel, the nvidia drivers and my graphics chip? – luke.tunmer Jan 14 '14 at 22:42
  • After deciding to use the nvidia-current version (which really is the version 304) I could get it back to running the X server, but still there is no unity launcher or toolbar. I ran the ccsm tool, and found that the Unity plugin was not turned on. But turning that on (and rebooting) still failed to do restore the unity trappings. I'm still having to switch to the console to modprobe the nvidia_304 driver before X will launch every time the machine reboots. – luke.tunmer Jan 16 '14 at 9:36

I did give up in the end and re-installed 13.10. That restored some sanity, and it reverted to the nouveau driver. I haven't quite had the courage yet to switch to one of the proprietary drivers. There still seem to be problems with the restore from a suspend, however.

| improve this answer | |
  • Switching to the nvidia-319-updates driver fixed the suspend problem. – luke.tunmer Jan 19 '14 at 15:59
  • Very sad to hear there's no solution other than reinstalling. I've read probably every popular answer in the subject trying to resolve this in any way other than reinstalling. Installing fresh is going to cost time. I might as well try a different OS – ido Feb 5 '14 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.