6

In my campus, some people they are using netcut in Windows and they are blocking us not to use Internet.

Since I am a Ubuntu user, I can't install neither nutcut nor netcut-defender to protect and even I tried TuxCut. It's is also not working properly.

Can any one give me the right solution for this?

  • before asking the question I was looking for the similar one's but in that problem they TuxCut as the solution but it is not installing properly in machine(13.10) thats why I asked this whether is there any other things are existing to protect ? – Suresh Jan 13 '14 at 19:28
  • Contact the admin at the campus and report the problem. The admin can easily find out the ones who are responsible for doing this and they will face serious consequences. If you start using similar softwares (on a network which is not yours) you will likely breach legal boundaries. – falconer Jan 14 '14 at 15:33
  • See also this security.stackexchange.com answer and this post – Pablo Bianchi Apr 13 '19 at 7:38
3

Try ArpON, it is already in Ubuntu repository:

sudo apt-get install arpon

sudo arpon -i eth0 -d

References:

  • 1
    It's not protecting from TuxCut. Is there any other solution ? – shyammakwana.me Sep 29 '15 at 12:38
2

Try changing macaddress. It will remove you from the list of the attacker.

  • Figure out Network Interface name which connects you to wifi

     sudo ifconfig
    

If ifconfig is not installed

    sudo apt install net-tools
  • This will give you a list of network interface card. Some of them are for bluetooth, wifi. Note down the name responsible for wifi connection. For my PC it was wlp3s0

  • Now install macchanger

     sudo apt-get install macchanger
    
  • Turn off the network interface card

    sudo ifconfig wlp3s0 down
    
  • Randomly change macaddress

     sudo macchanger -r wlp3s0
    
  • Turn on the network interface card

    sudo ifconfig wlp3s0 up
    
  • Turn off wifi and turn it on

Macaddress is changed, internet will work fine. This changes macaddress temporarily. Upon restart you need to change address again.

  • Tuxcut did not work properly for me too. But this worked fine – Nimish Agrawal Oct 30 '18 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.