8

I'm trying to get this ASUS USB-AC56 adapter installed on Ubuntu 12.04, but when I try to extract the Linux file from the cd, it says I don't have the right permissions to extract. I tried downloading the driver from the ASUS website but I can't install it. I don't know the proper syntax. Can anyone help me out?

  • Please edit your question to add the details of your wireless device from the terminal command: lsusb – chili555 Jan 13 '14 at 16:11
8

If lsusb says that the device is 0b05:17d2, then you need the driver 8812au. With a temporary wired ethernet connection, open a terminal and do:

sudo apt-get install linux-headers-generic build-essential

Please check here: https://github.com/abperiasamy/rtl8812AU_8821AU_linux On the right hand side, click 'Download ZIP.' Assuming downloads go to your Downloads folder, open the folder, right-click the zip file and select 'Extract Here.' Open a terminal and do:

cd ~/Downloads/rtl8812AU_8821AU_linux-master
make
sudo make install
sudo modprobe 8812au

It 'makes' with a couple of warnings on my 13.10 system, but no errors. I can test no further since I haven't the device. This is a rather new device and we'll be very interested in your report.

Whenever a later kernel version, also known as linux image is installed by Update Manager, after you reboot, you will need to re-compile the driver:

cd ~/Downloads/rtl8812AU_8821AU_linux-master
make clean
make
sudo make install
sudo modprobe 8812au

To gather further data, open a terminal and run:

lspci -nn > wifi.txt
lsusb >> wifi.txt

Find the file wifi.txt in your user directory and transfer it on a USB key or similar to a working, connected computer. Go here: http://paste.ubuntu.com/ Copy the entire text document and paste it in the text block. Click 'Paste!' A link will be created which you can then copy to post here. Here is an example: http://paste.ubuntu.com/6751980/ Then we can examine the result and advise you further.

If you are having trouble connection, please try right-clicking the Network Manager icon, select Edit Connections, select Wireless and then Wireless Security. Input the name of your network and carefully input your WPA password. http://i.stack.imgur.com/4OoHG.png

Next select IPv4 settings and, under BSSID, input the MAC address of your access point; confirm with:

sudo iwlist wlan0 scan

Please see this example. http://i.stack.imgur.com/C8Z6w.png

Now can you connect?

I notice in the manufacturer's specifications that this is specifically a USB3 device: https://www.asus.com/Networking/USBAC56/#specifications Are you attached to a USB3 connection on your computer? Check:

lsusb -vv | grep bcdUSB

I wonder if your device will operate correctly without the advanced features of USB 3.0 and whether it is backwards compatible.

Do you have a USB3 connection available?

  • Thanks, chili555. For some reason it downloaded the file to Home folder, but I moved it to Downloads and it worked. But, I'm trying to connect to my network router and it won't. The Wireless Authentication Required window keeps coming back for my password. I click connect but it won't. Any ideas? – user230824 Jan 13 '14 at 19:09
  • HI, chili555. I tried rebooting and it works like a charm now. Thank you so much. I'd never thought I could work this out. I've only been using Ubuntu for a month, and always had trouble with installing drivers. Again, thanks. – user230824 Jan 13 '14 at 20:13
  • This is so so frustrating chili555. I was connected when I rebooted. Checked my router connections. Saw it listed in the client column, turned around and it was disconnected. The Wireless Network Authentication Required window keeps popping up. Help! – user230824 Jan 13 '14 at 20:31
  • This is a newer device and an unknown driver so we are in experimental territory here. Are there any settings you added in Network Manager? Usually you need none. Is the behavior the same with wireless N turned off in the router. – chili555 Jan 13 '14 at 23:13
  • 1
    This paste looks much better! It shows 'asking for new secrets' i.e. your WPA key. It fails on 'failed (reason 'no-secrets'). Did you have a balloon pop up asking for the key? Did you input it? I am preparing an edit in a few moments. – chili555 Jan 15 '14 at 14:46
1

Although an old question, one additional driver is found at https://github.com/codeworkx/rtl8812au_asus. To install the driver you have to run make and sudo make install. I find this driver to work better than any other found online. Keep in mind though that dkms install is not setup and therefore you will have to install the driver manually on each kernel upgrade.

Bear in mind that for Ubuntu versions after 14.04 the drivers need to be signed otherwise Secure Boot will not let them load. So, even if the driver compiles it will not load. One solution is to disable Secure Boot or use the mokutil --disable-validation command

protected by Community Nov 1 '14 at 19:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.