Today I tried to change the alt+tab behavior of my Ubuntu because I did not like the grouped layout. I tried two shell scripts I found in a git gist. My problem is that since I used those scripts the behavior of Dash changed: when a program tries to notify me Dash appears for me (it is on auto-hide) and the application icon shakes for 5 seconds and it is often followed by the freezing of that application. Before I tampered with the settings it was shaking for only half a second and there were no freezing. How can I revert to the default settings?

I tried unity --reset but I received error messages (complaining about the lack of opengl and ending in a Segmentation Fault). I tried removing and reinstalling Unity and Compiz:

apt-get remove unity --purge
apt-get remove compiz --purge
apt-get install unity
apt-get install compiz

but nothing changed. How can I reset to my previous state (before running the scripts)? Some of my apps are freezing ever since I ran them although I reverted the changes in the shell scripts.


Though the methods outlined in the other answer work for 12.04 to reset Unity, If you would like to revert the state cleanly and completely, you will need to use ppa purge to purge the two ppas that were added, re-install the packages that the script removed, and hope it solves the problem.

sudo ppa-purge ppa:webupd8team/java
sudo ppa-purge ppa:noobslab/mint
sudo apt-get install zeitgeist zeitgeist-core zeitgeist-datahub python-zeitgeist rhythmbox-plugin-zeitgeist geoclue geoclue-ubuntu-geoip geoip-database whoopsie ubuntuone-client* python-ubuntuone-storage* ubuntuone-installer* menu apt-xapian-index oneconf
sudo apt-get purge nemo

That partially reverts the changes done at the package level. I did not include a command to automatically uninstall all that were installed by the script for fear of removing something you need.

As a general rule, do not run a script if you are not sure what it does. It adds ppas and does not update apt before installing, so I have absolutely no idea why they were added in the first place. It installs a lot of stuff that was added probably only for his specific needs. Worse, that script made no backup of current settings, so they are lost forever.

  • But if the per-user preferences are not resetted, you are not doing anything. I could purge zsh but that will not remove my ~/.zsh* files in my home ;). – Braiam Jan 14 '14 at 13:20
  • Gconf is the older version.. Not dconf. – Seth Jan 14 '14 at 15:24

You should be resetting the gsettings/dconf/gconf parameters instead. Those are found in your home directory in .conf or .dbus. So to effectively reset the settings:

dconf reset /com/canonical/unity/launcher

There are more aggressive like moving the .conf directories:

mkdir ~/dot.bk/
mv ~/.conf/dconf ~/dot.bk/
mv ~/.dconf ~/dot.bk/

Restart your session.

unity --reset

in terminal, of course...

or try this script. just install it:

sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
sudo apt-get update
sudo apt-get install unity-tweak-tool

and when you install it, just exectute this command:

unity-tweak-tool --reset-unity

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.