I'm trying to install Lubuntu 12.04 LTS on my iBook G4 as the OS X 10.4.11 really isn't all that great. I originally tried to use the minimal CD, but that failed as you can see by my question here: https://askubuntu.com/questions/396885/choose-a-mirror-of-the-ubuntu-archive-on-lubuntu-13-10-minimal-install. I think that issue may be caused by this same issue, as there I believe there is no actual internet connection.

So, I decided to try the full 12.04 CD, but I am now getting an error during the boot:

...stuff here (logo and other boot messages - all unrelated)
*starting configure network device
[ 110.081458] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
[ 110.081669] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
[ 110.081870] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware
and download the correct firmware for driver version. Please carefully read all
instructions on the website.

This is most perturbing. This post says that 10.04 works fine, but since 10.04 is EOL, I don't want to install it. This question suggests using the LiveCD with b43-fwcutter driver and trying to push ESC during the boot to see any errors. Also, would pushing Shift during the boot help any?
I probably will have to blacklist the b43 driver, but I'm not sure how.

There is a bug regarding this here: https://bugs.launchpad.net/ubuntu/+source/casper/+bug/956677 and the suggested solution is blacklisting the driver in the kernel param string, but again, I have no clue how to change the param string. I'm going to research blacklisting a little more, but since I am using the CD, I can't download/install drivers, like I could on USB (my iBook refuses to boot USB, even with Open Firmware hacking.) EDIT: I have looked around for blacklisting

This blog post: http://clusterbleep.net/blog/2012/05/09/ubuntu-12-04-splash-screen-lockup-with-livecd/ is exactly my issue, but I never get a Install/Disk Options screen. Would holding Shift during the boot allow me to get to this? I have to hold C and then enter live to start the LiveCD and then I would hold Shift.

How do I fix this issue? The system is a July 2005 iBook G4 1.33GHz PPC/512MB RAM/40GB HDD/unsure what graphics card/and as can be seen from this issue probably a Broadcom B43 internet chip thingy.

  • Can I ask a question about both of the correct answers? How do I get to a prompt to that will allow me to run the command "sudo b43-fwcutter /lib..."? And , where do I download the firmware from? Thank you in advance and I am sorry if this is not the proper procedure. – user37890 Apr 14 '14 at 5:01

Installation Instructions for Broadcom network devices

First you will have to identify your chip ID as each one is supported by more than one driver/module.

Run this command to know your network chip details ('14e4' to find only broadcom devices)

lspci -vvnn | grep 14e4

It will display something like this:

03:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

Now here,

The Chip ID is BCM4322

The PCI-ID is [14e4:432b]

Your chip id will be different. Now when you know your chip-id, find the driver supporting your network chip from this official ubuntu page: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#b43%20-%20Internet%20access

The page has installation instructions for each driver as well.

Don't forget to reboot your system after driver inslalation.

Hope it helps.

With a wired connection, install the firmware package:

sudo apt-get install linux-firmware-nonfree

Now the b43 driver should work. If you started blacklisting things, undo all that, nothing else is needed.

up vote 2 down vote accepted

I solved this on my own, so I'm creating a self-answer.

I downloaded the firmware manually on another PC and then ran the command sudo b43-fwcutter /lib/firmware FIRMWARE/FILE/LOCATION/HERE/wl_prebuilt.o

Then I restarted and it works!

This is the terminal command that works for me.

sudo apt-get install firmware-b43-installer

-many blessings

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.