I've been looking around for solutions to this and can't really seem to find a good answer so I thought I'd try this. I'm trying to install MATLAB 2013a on Saucy Salamander. I have all the files already downloaded and extracted to my Desktop. The installation files are for Linux 64 bit. This is what I'm doing and getting on the terminal (keep in mind I'm completely new to Linux and Ubuntu):

sudo ~/Desktop/matlab/install -v
[sudo] password:
sudo: /home/(myname)/Desktop/matlab/install: command not found

I tried doing things differently by moving the MATLAB folder to a different location (i.e. Downloads) and trying this:

cd ~/Downloads/matlab
sudo ./install
[sudo] password:
sudo: /home/(myname)/Downloads/matlab/install: command not found

If you guys know a better solution/what I'm doing wrong, please let me know.

  • Drop the 'sudo' in front of the commands. – Rinzwind Jan 11 '14 at 16:40
  • I tried that and I get "permission denied" – wsheikh92 Jan 11 '14 at 18:28
  • Remove everything. You have mixed permissions. Do not use sudo next time. – Braiam Jan 11 '14 at 20:35
  • sorry i'm not sure I follow? are you saying I should uninstall MATLAB and start over? What does "mixed permissions" mean? – wsheikh92 Jan 11 '14 at 20:55
  • Try in 64 bit ubuntu OS. Unless you can't... – user264808 Apr 3 '14 at 4:52

Reposting the solution provided by the OP in the question

Alright! After doing a little bit of digging, I figured out how to do it! Here's the step by step method to (hopefully) solve the issue for anyone having the same problems:

If you have the .tar.gz file for MATLAB, be sure to right click it and extract it to folder (I did this in ~/Downloads).

Open terminal and type the following:

cd ~/Downloads/(matlabfolder)  
sudo chmod +x ./install  
sudo ./install

You will get an error that says:

eval:1:/tmp/mathworks_6114/sys/java/jre/glnxa86/jre/bin/java: Permission denied

Then, navigate to that directory and do the following:

cd ~/Downloads/(matlabfolder)/sys/java/jre/glnxa86/jre/bin
sudo chmod +x ./java

Then, go back to the install directory that you went to initially:

cd ~/Downloads/(matlabfolder)
sudo ./install

That should launch the MATLAB installer! If you find my instructions unclear, this is where I got my info!

For those who are wondering, I think that the chmod +x function basically makes the file you specify to be executable.

Hope this helped!


Check if the install file actually has executable permissions. If not, run the command chmod a+x install and then try sudo ./install again.

You may get an error ./install: 1: eval: /tmp/mathworks_4880/sys/java/jre/glnxa64/jre/bin/java: Permission denied, then run the command

chmod +x ./sys/java/jre/glnx86/jre/bin/java and then try the sudo ./install again.


I have also received permission denied at other folder line /sys/glnxa64/install_unix . So go the folder and open terminal. change permission using chmod +x install_unix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.