1

I'm curently Dual-booting between Windows 7 and Ubuntu 13.10 both are 32-bit

I'm installing it on a HDD with Ubuntu Bootloader installed on an external Pendrive (So if i want to boot Ubuntu i must load the bootloader from the Pendrive).And it works

My problem is,since i'm installed it on a PC which already has an OS,the Installer install the GRUB for dual-booting and it always show GRUB Menu that ask me to choose which OS i want to load (But it only appear when i'm boot from the Pendrive)

what i'm trying to do is make my GRUB bootloader to boot directly to Ubuntu without showing GRUB Menu.I've followed guide from here but my GRUB menu still appear

here is what contained on /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

What i've tried

-Do as guided

-Set default to Ubuntu by run sudo grub-set-default Ubuntu

But those all seems do nothing and my GRUB Menu is still appearing

am i missing something ? does implemetation of the linked guide is diffrent for Bootloader installed on external drive ?

Thankyou

0

After editing /etc/default/grub, did you perform this command from a terminal?

sudo update-grub

If you missed that step, that is probably why you are still getting the grub menu.

  • Yes i did.Even twice Twice with sudo once without sudo which give me an error – Tommy Aria Pradana Jan 11 '14 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.