I'm trying to use Software Properties (software-properties-gtk) to install nvidia drivers. When I open the Additional Drivers tab it just says "searching for additional drivers..." and then Apport comes up telling me Ubuntu has had an internal error. The available additional drivers never show up, the list just stays empty.

When I run software-properties-gtk from the terminal I get the following output right before the crash:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/gi/overrides/GLib.py", line 634, in <lambda>
    return (lambda data: callback(*data), user_data)
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 1323, in show_drivers
    (overall_status, icon, drivers) = self.gather_device_data(self.devices[device])
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 1277, in gather_device_data
    description = base_string.format(base_description=description, licence=licence)
KeyError: 'license'

Is this a known bug? Can I fix it?


Edit the /usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py and correct that typo! Find "licence" and replace it with "license"!

That did the trick for me :)

| improve this answer | |
  • I find 6 occurences of "licence" and those seem to be consistent. Did you change all of them? – Raffael Apr 18 '14 at 11:39
  • Yes i changed all of them and then the additional drivers tab works again. – Joakim Fogelström Hardingz Apr 18 '14 at 15:33
  • No fix for this yet it seems. Its affected 3 out of 4 different machines for me so far. The common denominator i've spotted so far is the crash occurs whenever options to use proprietary graphics drivers are provided, which should affect A LOT of people. Correcting the typo fixed the problem in all 3 cases... – Joakim Fogelström Hardingz Apr 25 '14 at 0:32
  • The fix is out since a while, and so, this shouldn't be an issue for updated systems at all anymore. See bug bugs.launchpad.net/bugs/1319257 – Beamie Jul 18 '14 at 18:37

First of all, it will be easier for you to solve your particular problem if you install jockey-gtk. jockey-gtk will make it easier for you to open Additional Drivers. jockey-gtk is available in the Ubuntu Software Center in Ubuntu 13.10. Open the terminal and run:

sudo apt-get install jockey-gtk

  1. Search for jockey-gtk in the Dash.

  2. Click on the Additional Drivers icon to open Additional Drivers.

  3. A little Additional Drivers window will open with an orange bar moving back and forth. It will start searching for additional drivers. Let it search for additional drivers for at least 3 minutes.

  4. Close Additional Drivers from the Launcher or if you can't close Additional Drivers from the Launcher, kill the Additional Drivers processes (software-properties-gtk and jockey-gtk) in the System Monitor.

  5. Open Additional Drivers again. This time the available additional drivers may show up in Additional Drivers.

| improve this answer | |
  • I guess I spelled that out wrong: There are no search results at all when typing "Additional Drivers" in the Dash. So I'm stuck at step 2 in your answer. – Lars Nyström Jan 11 '14 at 13:39
  • I actually didn't know Ask Ubuntu had a limit on comments, but sure I've deleted some of them! I really appreciate your help, and I'm sorry for the confusion about which version I'm on. – Lars Nyström Jan 11 '14 at 18:23
  • Had the same problem with software-properties-gtk crashing on additional drivers search in 13.10. With jockey it worked. Thanks karel. – Beamie Jan 31 '14 at 7:50
  • Forgot to say - i worked for me with jockey-kde. Which means youll get a lot of kde-packages installed too, but its a workaround until a fix is available. – Beamie Feb 1 '14 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.