I am using a Dell Vostro 3560 with Win 7 x64 and Ubuntu 12.04 as dual boot. Earlier my room WiFi was getting detected in both Ubuntu and Windows 7. But recently I moved to a different location (country) and the WiFi in the hostel doesn't seem to be detected by Ubuntu, although I can connect it from Win 7 and it works fine in windows. Ubuntu shows a lot of other WiFi connections (available in that range); but wouldn't show the WiFi I need to connect to.

I have tried connecting using the hidden network option, but it doesn't work either. Can someone please help me on this?

Output of lshw -C network:

        description: Ethernet interface
        product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        vendor: Realtek Semiconductor Co., Ltd.
        physical id: 0
        bus info: pci@0000:01:00.0
        logical name: eth0
        version: 07
        serial: f0:1f:af:0d:08:ba
        size: 10Mbit/s
        capacity: 1Gbit/s
        width: 64 bits
        clock: 33MHz
        capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
        configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4
 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
        resources: irq:41 ioport:3000(size=256) memory:c2404000-c2404fff memory:c2400000-c2403fff  

        description: Wireless interface
        product: BCM43142 802.11b/g/n
        vendor: Broadcom Corporation
        physical id: 0
        bus info: pci@0000:02:00.0
        logical name: eth1
        version: 01
        serial: f8:2f:a8:bf:0e:e1
        width: 64 bits
        clock: 33MHz
        capabilities: bus_master cap_list ethernet physical wireless
        configuration: broadcast=yes driver=wl0 driverversion= (r326264) ip= latency=0
 multicast=yes wireless=IEEE 802.11abg
        resources: irq:17 memory:c2500000-c2507fff

Also, I found out that its a Comtrend 802.11n Gigabit Router. Any help?

  • Maybe you can give WICD a try? wicd.sourceforge.net – Christophe De Troyer Jan 14 '14 at 10:29
  • 1
    Do you have a live CD? Does it connect fine from there? – virtualxtc Jan 15 '14 at 11:06
  • @virtualxtc Once I boot into live CD, the wireless networking isn't enabled and asks me to install a broadcom driver, with a lan card image. – Anupam Jan 18 '14 at 15:18
  • 1
    run lshw -C network (and put the output in your question), it will tell us what wireless card / chip-set is being used; we can then google for the proper linux driver, or an inf to download. – virtualxtc Jan 21 '14 at 1:31
  • Updated my post with output – Anupam Jan 23 '14 at 18:35

Boot from the live CD and see if you can make a connection that way.

If wireless does work via the live CD, then you can try reconfiguring your network, or just copying over the network-manager config files:

  • Re-configuring the network:

Open a terminal and type

sudo dpkg-reconfigure network-manager 


  • Copying over the settings used by the liveCD:

Boot from a live CD, back up your old network settings, clear out any system connection file and copy over the ones from the live CD.

Open a terminal and type the following to become root:

sudo su

then backup,:

mv /media/<Name of your Ubuntu Partion>/etc/NetworkManager/NetworkManager.conf /media/<Name of your Ubuntu Partion>/etc/NetworkManager/NetworkManager.conf.broken


rm /media/<Name of your Ubuntu Partion>/etc/NetworkManager/system-connections/*

and copy:

cp /etc/NetworkManager/NetworkManager.conf /media/<Name of your Ubuntu Partion>/etc/NetworkManager/NetworkManager.conf
cp /etc/NetworkManager/system-connections/* /media/<Name of your Ubuntu Partion>/etc/NetworkManager/system-connections/

Reboot the system without the live CD and you should be good to go.

  • I tried using live CD, but the wireless networking isn't enabled. What it asks me to do is 'Activate' a Broadcom driver with a lan card image. But since there is no internet the activation (or basically installation) fails. FYI, I have this Broadcom driver activated in my actual Ubuntu OS, and I tried disabling that to check if the WiFi works but it doesnt. – Anupam Jan 18 '14 at 15:20
  • ouch, sounds like ndiswrapper is the way to go then. – virtualxtc Jan 18 '14 at 16:41

You could just try to manually add it. Go under your internet and click "edit connections" and add a server from there manually. Note you have to know the server's name and password in order to add it.

  • Can you explain how to do that? With screenshots preferably.. – Seth Jan 16 '14 at 3:41
  • I can't take screenshots with my crummy computer (sorry about that), but I think I can explain it a little better. In the top right corner when you log in click on the internet bar, or the thing that shows how good your connection is then on the very bottom hit "edit connections". Once you open that click the wireless tab and hit add on the very right of the tab. Insert the name and password of your server and see if it works. If not I don't know what the problem is. – ljbeuk Jan 16 '14 at 3:48
  • You should edit the information into your answer to fill it out some :) – Seth Jan 16 '14 at 4:06
  • Ok do you know what I mean when I say the internet bar? – ljbeuk Jan 16 '14 at 4:08
  • Yes I understand. – Seth Jan 16 '14 at 4:09

Not sure if it works but you can try connecting through Connect to a hidden Wi-Fi Network... under the Network applet menu. Even if the connection is not hidden but you can connect to a specific Wi-Fi network. I tried this method with my wifi which is not hidden and it worked.

  • I have tried this as well, didn't work. – Anupam Jan 16 '14 at 10:32

Install ndiswrapper

sudo install ndiswrapper-common ndiswrapper-modules-1.9 ndiswrapper-utils-1.9

Install the WiFi driver (from Windows):

sudo ndiswrapper -i yourdriver.inf

Check the driver is working:

sudo ndiswrapper -l

Load the module:

sudo depmod -a

sudo modprobe ndiswrapper

Configure modprobe so that it loads ndiswrapper:

sudo ndiswrapper -m

Edit the modules to add ndiswrapper at the end:

sudo gedit /etc/modules

Remember to add ndiswrapper at the end.

Hope you now have your WiFi back!

  • Could you please tell me what I need to provide in place of 'yourdriver.inf' ? – Anupam Jan 18 '14 at 15:21
  • the windows 2000 or greater inf file that matched you wireless card. You should be able to download it from the vendors product page. – virtualxtc Jan 18 '14 at 16:43
  • @virtualxtc You mean the msi/exe file that I installed for Windows 7 64 bit and downloaded from dell official website? Sorry about the noob question, but I am using Dell Vostro 3560; so do I download from the official dell website? – Anupam Jan 18 '14 at 17:25
  • see my comment on your question. – virtualxtc Jan 21 '14 at 1:31
  • Is there any wireless device that actually needs this workaround anymore? Also you would need to have internet connectivity to run that install. – NoBugs Feb 7 '14 at 2:44

Wireless drivers are updated from kernel to kernel, version to version - I remember 9.04 had poor support compared to 10.x and newer, for example.

You may need to install/upgrade 13.10 (or 14.04 in a couple months) and make sure you have the latest updates installed, for best support - especially if it's a newer laptop nic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.