5

When I try to open any OS on Oracle VirtualBox an error accurate.

Failed to open a session for the virtual machine xp efendi.
AMD-V is being used by another hypervisor. (VERR_SVM_IN_USE).
VirtualBox can't enable the AMD-V extension. Please disable the KVM kernel extension, recompile your kernel and reboot (VERR_SVM_IN_USE).

How can I repair this problem?

1
  • I can not find any solution on Internet for Ubuntu.
    – Huseyin
    Commented Jan 10, 2014 at 19:16

5 Answers 5

4

This error is because you have virtualbox and kvm installed. The kernel modules conflict.

The "simple" solution is to use one or the other, but not both. You can, however, use both as long as you are willing to manually (or script) loading / unloading the kernel modules.

To see your modules

#Virtualbox modules
sudo lsmod | grep vbox

#kvm
sudo lsmod| grep kvm

To remove a module

# remove virtualbox
sudo rmmod vboxdrv
sudo rmmod vboxnetflt

#remove kvm
sudo rmmod kvm
sudo rmmod kvm_amd

use insmod

sudo insmod /full/path/to/your/modules

You can find the module with

locate kvm | grep .ko
locate vbox | grep .ko

Use the modules for your current kernel.

3

This problem has solved by following codes in terminal:

sudo killall VBoxSVC
export VBOX_HWVIRTEX_IGNORE_SVM_IN_USE=true
VirtualBox
2
  • 2
    I ended up having to remove kvm and kvm_amd, blacklist them, and do this when I run my VM. But it's working now! Commented Jan 23, 2015 at 1:53
  • @DanielBuckmaster Thank you very much for sharing your solution. It is very easy and solves all the problems.
    – Pavel_K
    Commented Jun 29, 2022 at 10:39
2

For me, there was no kvm module loaded (lsmod | grep kvm, shows nothing), thus it was enough to simply set the VBOX_HWVIRTEX_IGNORE_SVM_IN_USE=true as Huseyin pointed out.

For my particular case when I was running virtualbox without sudo, my existing win 7 vdi was trapped in a recovery console screen. (every action eventually restarted my machine) Maybe some permission issues, (solved by running sudo virtualbox, however I'm not sure this is the recommended way)

Another great read about how to script your way into "Using KVM and VirtualBox side by side" http://www.dedoimedo.com/computers/kvm-virtualbox.html

2
  • How can I would be able to set permenantly?
    – Huseyin
    Commented Apr 18, 2014 at 19:39
  • @Huseyin add it to your .bash_profile or somewhere else that gets run on login (make sure to export, not just set the var). Commented Jan 23, 2015 at 1:53
1

I solved that problem by closing Docker Desktop so be sure you have turned off docker or other virtualization technologies.

1
  • Closing Gnome "Boxes" (another VM client) worked for me too
    – Dr-Bracket
    Commented Oct 1, 2023 at 7:35
0

Run System Monitor, search for KVM and kill it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .