7

Software Updater has installed some new software. I'm largely not interested in this fact as I just use this machine as a file server and watch everything on my tablet or Windows machine.

However, every time I connect to the machine, I see this:

enter image description here

This is a window with no close button with the "Restart" button selected by default so literally my next keypress will reboot the machine. This is almost as bad as Windows 8 rebooting whenever it wants to in order to apply updates.

I don't mind it installing updates as and when it wants to but I am only ever going to restart the machine when I want to restart it. How can I stop the Software Updater from nagging me to restart?

  • Move it to a different workspace and it won't even bother you(It's not a solution but just an escape) – nitishch Jan 10 '14 at 13:11
  • Since you're using this as a server, why not just use Ubuntu Server? It is intended to be used as a server, so the options for how it deals with updates are better suited for what you're doing. – David Oneill Jan 10 '14 at 14:13
  • Ubntu server also has updates.so the problem will continue. – Registered User Jan 10 '14 at 14:53
  • What if you are using Ubuntu server with ubuntu-desktop added? then you have the same problem.... – Alvar Jan 10 '14 at 15:01
  • The Server edition allows more choices as far as installing updates. I know for sure you can set it to only install updates manually which would solve the problem. IIRC, you can also schedule it to run updates (and get reboots out of the way) at a certain time IE in the middle of the night. – David Oneill Jan 10 '14 at 19:58
3
  • Launch dconf editor the way you want, maybe Dash
  • Click Ctrl+F and search for hide-reboot-notification and click next

enter image description here

  • Click the checkbox and you are done!!!
|improve this answer|||||
  • 1
    This wont stop the window from coming up this will just make you ignore it. it's pretty much the same as moving it to another workspace. – Alvar Jan 10 '14 at 15:00
3

dconf-editor on Trusty doesn't have a hide-reboot-notifications option, but adding one with the following command appears to work:

dconf write /com/ubuntu/update-notifier/hide-reboot-notifications true

I tried using gsettings set but it complained that the key didn't exist. So far dconf write has stopped the reminder appearing, and the setting is now visible in dconf-editor.

|improve this answer|||||
1

Use xkill.

I am using Ubuntu 12.04 so that's what I'll use for the instructions.

Go to "system settings"->"keyboard"->"shortcuts" tab

In the left sidebar, select "custom shortcuts" and then press the "+" sign at the bottom to add one.

In the window that pops up, type xkill in both fields for name and command. Apply.
Click on the word "disabled" in the new shortcut and it will change to "New accelerator..."

Press your key combinations to activate xkill. I use Ctrl+Alt+X .

Now, every time that window shows up (or a window hangs), just press the key combination and your cursor will change to an X shape. Click on the window to kill it. To cancel just right click anywhere.

NOTE: If you have any unsaved data in the window you select when doing this, it will be lost.

|improve this answer|||||
1

How about just using:

killall update-manager

Anyway, my opinion is that you should disable the update manager at startup and in synaptic options (Configuration > repositories > updates > check updates automatically: never), since I agree, it is really annoying.

Of course, you WILL NEED to acquire the habit of do a manual update instead, or even schedule it with some tool (like cron). In order to be updated you must type regularly:

sudo apt-get update && sudo apt-get dist-upgrade -y
|improve this answer|||||
0

Kill software-updater by running the below command,

sudo kill $(ps aux | grep software-updater | awk '{ print $2 }')
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.