2

I am able to install Ubuntu 11.04, but I have to pass the noahci (or ahci=off) parameter to the kernel as part of the installation process. Once the installation process is complete the system will not boot.

By removing the following items from the kernel line in the GRUB configuration I can somewhat see what is going on:

vt.handoff=7
splash
quiet

Also, I've been changing the 'gfxpayload' parameter to 'text'.

Under these conditions I can observe the boot process. When I get to the running scripts portion the text font appears to change. It goes from a bright bold white to a more muted, non-bold white. Then the screen goes blank and I'm again stuck.

I can ping the machine, but I can't ssh in as ssh is not enabled.

I have a Dell Precision T3500 with an NVidia video card with DisplayPort outputs.

My problem seems similar to this askubuntu question.

1

Passing the following parameters to the kernel on the 'linux' line solved the problem:

pci=noacpi,nocrs acpi=off pcie_aspm=off

For good measure I also removed these items from the 'linux' line:

quiet
splash
vt.handoff=7

I also changed the 'gfxpayload' to 'text'. This allowed me to actually see what was going on at boot.

0

You either don't have GRUB or GRUB's display isn't working with your monitor (like mine didn't)

I'm entirely sure but after your splash screen, try pressing enter when your screen is blank and it might boot the OS that would of been first in GRUB's list.

either install grub (sudo apt-get install grub) OR if you manage to boot the first OS it means your monitor can't display however GRUB displays... Install the Start-up Manager (search it Software Centre). Then increase all the screen resolutions and colour depths etc etc. Worked for me :)

  • I don't know why GRUB wouldn't be installed. Is there a situation where Ubuntu would not install GRUB? – Rob Jones May 5 '11 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.