I disabled the avahi-daemon according to the method set out here, namely editing the /etc/init/avahi-daemon.conf file to:

start on (never
          and filesystem
      and started dbus)
stop on stopping dbus

After a reboot, I now get from service avahi-daemon status (or initctl list | grep avahi)

 avahi-daemon stop/waiting

Which sounds like I have successfully disabled the service.

However, in my syslog at boot I see :

dbus[991]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out
dbus[991]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out

This seems to cost me half a minute of extra boot time...How can I disable this trying to launch avahi?

  • 1
    Depends, does the override method get rid of the dbus message?
    – fpghost
    Jan 9, 2014 at 15:35
  • I would start there, if that doesn't work update your question so we can rule it out Jan 9, 2014 at 15:54
  • 1
    Btw, that method is from 2009. Obviously shouldn't work now.
    – Braiam
    Jan 9, 2014 at 17:42

1 Answer 1


dbus[991]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out

This means that it failed to connect to the service since it's not running. The 30 seconds you spend waiting is not because the service is starting, is because another process expects the service to be running when dbus tries to access the key. If you want to really stop Avahi you should instead remove the package:

sudo apt-get remove avahi-daemon

There isn't a sane way to deactivate the daemon without messing with other networking services.

Not the answer you're looking for? Browse other questions tagged .