9

I've read the forums, I looked at that page that everyone posts on. I don't mean to sound like a douche but can you guys just seriously help a noob out and recommend a USB wifi device that works in both windows and linux out of the box or atleast has first party ready to install drivers? Please do not post that link i've seen on previous posts. Just a simple "ya try this one it's awsome" would be far less ambiguous and helpful for me. Ive tried two adapters now and either of which works. One of them even has "linux compatible" on the box yet it doesn't even have its own set of drivers for linux. I'm just really frustrated and would like some recommendations.

6
  • Which two adapters have you tried? – user25656 Jan 9 '14 at 6:33
  • Just 1 rule: avoid broadcom. "yet it doesn't even have its own set of drivers for linux. " Here you make a false assumption: that is NOT how linux works. – Rinzwind Jan 9 '14 at 13:11
  • 1
    I see you are a very friendly user. Linux uses generic drivers so they will NOT be on a CD/DVD with the device. All drivers for hardware to work are basically already on your system but might need configuring. But as I said before: avoid Broadcom. It is a hassle and then some to get working. The one branded "linux compatible" will work. How do you expect us to help you if you do not even provide the details of that adapter? This question is nothing more than a rant and shows not the least intent in getting something fixed. I am voting for closing it. edit: or not :X – Rinzwind Jan 9 '14 at 13:57
  • Panda makes highly Ubuntu friendly WiFi adapters that will work with both Ubuntu and Windows. I was having issues my internal card and needed to do some troubleshooting and purchased this one: amazon.com/Panda-Ultra-Wireless-Adapter-150Mbps/dp/B00762YNMG They make others, including ones with external antennas. – Kendor Jan 9 '14 at 13:57
  • THanks kendor, I will check that out. Rinzwind, you could have just said that to begin with. As I said I am new. For adapters I tried a asus usb-n53 and another one which i forget the name for. I went to the ubuntu documentation site and tried a Dlink DWA-160 which sais it will work out of the box but doesn't :/ – user233527 Jan 9 '14 at 19:05
4

Look at this page : WifiDocs It worked perfectly for me !

2
  • 3
    What did you end up buying which worked? Very few of the products I see in stores are listed there. – greggo Feb 8 '15 at 22:53
  • That's just a collection of devices. No sorting by relevance/up-to-dateness possible. – scai Jul 21 '16 at 19:43
0

Most of the new Ubuntu-versions already come with working drivers for a lot of common wifi adapters. I randomly bought two sticks (both from CSL) from Amazon (Germany) and they both worked out of the box in 13.4 and 13.10 (older versions did not work directly for me).

4
  • "a lot of common wifi adapters" - still a crap-shoot. Here's one data point: avoid the Hiro H50191. It uses a multiply-assigned USB ID, so the wrong driver gets loaded; the 'right' driver from realtek won't build against more recent kernels. The 'wrong' driver which does get loaded gives me 4 mbit/sec. – greggo Feb 8 '15 at 18:56
  • if you randomly bought two sticks and they worked, please say what they are. Include the USB ID (from lsusb) and the FCC ID (which contains the hardware rev). I just got back from Tiger Direct with a TP-LINK TL-WN727N - which I picked because it the only one they had which I could find on the 'WifiDocs' page provided by Laurent above. But there is no standard driver for this, and the driver from ralink (now mediatek), I've just downloaded, says "supports kernel 2.4 and 2.6'. This whole situation is utterly appalling. – greggo Feb 8 '15 at 22:52
  • Wait: this worked for a 3.13 kernel: github.com/porjo/mt7601 But, it won't build under 3.2 (12.04 LTS), which is the machine I wanted it for. Easier to upgrade that server than to keep trying random wifis, I guess. For the record, the usb ID is 148f:7601 and the FCC ID is TE7WN7727NV4 – greggo Feb 8 '15 at 23:34
  • It was this one amazon.de/gp/product/B007K871ES as well as this one amazon.de/gp/product/B00A7UH40M . Since I switched to cable anyways I do not own them anymore, so no USB ID, sorry. – BenSower Feb 9 '15 at 21:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.