I am running Xubuntu 13.10 (monitor attached) with x11vnc 0.9.13-1.1 run with the following options:

x11vnc -gui tray=setpass -rfbport PROMPT -bg -o %HOME/.x11vnc.log.%VNCDISPLAY

I have also enabled after x11vnc was up and running..... shared, forever, ultravnc file transfer, and a password for full permissions (no password for view only)

I am running UltraVNC x64 Viewer from my Windows 7 machine and I am able to connect to my Xubuntu just fine but what appears on the screen is a black desktop with nothing on it (no icons, no panels, etc...).

What is strange is that the following 2 things are true when I'm in this state using UltraVNC viewer

  1. When looking at the Xubuntu machine's monitor I can see the mouse moving when I move it within UltraVNC. I can even drag the open windows on my Xubuntu desktop around. When I do this the outline of the window I'm dragging appears in UltraVNC... but only while dragging.

  2. If I click on the "Select Single Window" toolbar button in UltraVNC then click on any open window or anywhere on the desktop that window then shows up in UltraVNC and I can interact with it how you would expect. Clicking on the desktop shows me the desktop, but then if I try and open any application (or any other window) it does NOT show up in UltraVNC (as expected since I'm in single window mode) but it DOES show up on the Xubuntu desktop (again as expected). If I then click on "Select Full Desktop" it goes back to the black screen with the same behavior as before.

I searched this forum and also google but did not find anything that was helpful at all. Hopefully someone can offer some guidance as this has me stumped! I've tried using tightvncserver with the live CD, but I have found that it will sometimes open apps in display :0 if a monitor is connected to display :0 and the vnc viewer is connected to display :1. Also, I would rather have a shared view of display :0 and I know the x11vnc server provides this "out of the box".

Oh and I just tried this from my Ubuntu 12.04 machine using "Remote Desktop Viewer" and the behavior is exactly the same. So it doesn't appear to be an issue with the VNC client.


So it turns out this seems to be related to the color bit depth set for the vnc server. If I change the bit depth to be anything less than 32 I get full view/control of the desktop. However this has the annoying effect of missing icons in the file manager, desktop, dock, etc... I assume this is because the icons are 32bit color and there aren't any icons of a lesser bit depth for that application/folder/file. In the file manager, this results in EVERY folder icon being missing and a lot of the icons in the settings manager as well. I also have noticed a TON of errors in the vnc log file after xfce starts.

Oh and this was after switching to vnc4server. Apparently this is a known bug in Xubuntu.

Never found a solution for x11vnc but what I ended up going with is vnc4server and using LXDE as the desktop environment in the vnc session. Sadly, I haven't found a way to make vnc4server share display :0 with the physical monitor. However, at least I now have a working vnc desktop since this machine will ultimately be headless in a server room.

1 Answer 1


x11vnc faq headless entry says to create an xorg.conf file: http://www.karlrunge.com/x11vnc/faq.html#faq-headless

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – fossfreedom
    Apr 17, 2014 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .