7

I'm in 13.10 64 bit and I've installed wine from the official repositories. Running wineboot or trying to install any .exe gets me the following message:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so:
/usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file:
No such file or directory

I've tried the directions from the diferent answers here but there is no /usr/lib/i386-linux-gnu/ folder nor a gnome-keyring-pkcs11.so file in the gnome-keyring:i386 package from the official repositories (gnome-keyring_3.8.2-0ubuntu3.1_i386).

Should I be using a different gnome-keyring:i386 package version from the one in the official repositories?

  • Exactly what package did you install? Did you run sudo apt-get install wine? The best way to install wine is by adding it's official repository and installing wine1.7 from there. The official repositories are very outdated, so you could be experiencing a bug. – Dillmo Jan 9 '14 at 1:33
  • I installed with sudo apt-get install wine. I'm gonna go with the wine1.7 version then. – Cesar Jan 9 '14 at 12:26
  • @Dillmo: Okay, I installed wine1.7 as you suggested and tried again but I get the same message. – Cesar Jan 9 '14 at 12:52
  • I'm also experiencing this in Mint 16 with Crossover. Possibly related as other solutions (that used to work) no longer do. – Andrew Bolster Jan 9 '14 at 19:38
  • 1
    this worked for me. – toto_tico Jan 10 '14 at 12:07
7

I had the same problem with Ubuntu 14.4 on an AMD64 box;

Not sure how I ended up in that state, but it was obvious that, inside of firefox, the pipelight/silverlight plugin tried to load two dynamic libraries, and could not find them.

Both were attempted to be loaded as 32bit variant (more specificaly from a directory explicitly designated for 32bit libs.)

The related library files for 64bit architecture where present

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory

I read about some hackish approaches like ubuntuforums about "p11-kit error Workaround WINE in AMD64 Ubuntu 12.04, and tried to install packages with similar names to get the libs.

The tricky part was that the libs are not in the packages where you'd expect them from the packages name, but slightly similary named packages.

So, I found out that these two packages

p11-kit-modules:i386 and libp11-kit-gnome-keyring:i386

need to be installed to fix the two "couldn't load module" cases.


Note that this did not resolve a third error message line followed direcly to the the lines discussed above:

err:secur32:schan_AcquireClientCredentials Could not find matching protocol

protected by Community May 24 '14 at 18:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.