There are multiple posts/questions about this but none actually have an answer that I could find.

Just installed Ubuntu server 12.04. Added myself to the sudoers file, changed the networkmanager.conf from FALSE to TRUE (just so I could SEE/EDIT the network connections. Rebooted. Now I can get in there, but the Edit button for my wired connection is greyed out. So I find a post in the ubuntu forums that says to do sudo /etc/init.d/networking restart. I do that, then the console tells me this command is deprecated because it may not enable again some interfaces... and tells me to change it (ifupdown:managed=true) back to FALSE.

I just want to set a STATIC IP ADDRESS and I cannot believe it's taken me ~30 minutes to do this. Can anyone help me, the GUI way? I realize it may require some CLI but ultimately I'd like to get the GUI working the way it should.

I have tried "maximizing" the window to see if it uncovers an "unlock" button but there's nothing to be found.

  • 1
    If you want to use the GUI primarily, perhaps you should install Ubuntu desktop instead of server. Then you can add any server packages you actually need. Be aware that most server software on Ubuntu will need to be configured using the command line. On a GUIless server install, the suggested way to add an IP address is by editing /etc/network/interfaces (see man interfaces for information on the format). That said, you can install Ubuntu server, then install the ubuntu-desktop metapackage to get a working GUI. – roadmr Jan 8 '14 at 20:48
  • thanks @roadmr, now that I memorized the acronym AIANNBGD (each letter representing a necessary line in a static IP -- a=auto eth0, i= inet....,a=address,n=netmask,n=network,b=groadcast,g=gateway, and finally d=dns-nameservers), it takes me literally 1 minute to change the IP address in /etc/network/interfaces. – 00fruX Jan 29 '14 at 17:04

This is on a desktop 13.04 now (but I did it in my first installation around 11.04, upgraded and never changed since...). I did not change any configuration file by hand.

I clicked on the network manager and selected "Network settings". Choose the wired connection (I remember there was a glitch in which you have to change the name of it, it didn't work with the default one). Then select the connection as system one (so that it connects without the need to login):

Setting a system connection

and then in IPv4 settings configuring it as a static IP.

selecting fixed IP

I hope it still works...

(PS it's the same system, I have rotating backgrounds...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.