I have just installed Ubuntu 13.10 x64. After installing nvidia-319-updates and nvidia-settings-319-updates I don't have anything in additional drivers tab of software and updates. Additionally when I run nvidia-settings I get this:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

I don't have nvidia-xconfig

/var/log » sudo nvidia-xconfig
sudo: nvidia-xconfig: command not found

/var/log »      dpkg -l |grep nouveau ; dpkg -l |grep nvidia                                                                                                                                    d21d3q@zkomp
ii  libdrm-nouveau2:amd64                     2.4.46-1ubuntu1                          amd64        Userspace interface to nouveau-specific kernel DRM services -- runtime
ii  xserver-xorg-video-nouveau                1:1.0.9-2ubuntu1                         amd64        X.Org X server -- Nouveau display driver
ii  bumblebee-nvidia                          3.2.1-3                                  amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
ii  nvidia-319-updates                        319.60-0ubuntu1                          amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-common                             1:0.2.83                                 amd64        transitional package for ubuntu-drivers-common
ii  nvidia-cuda-dev                           5.0.35-7ubuntu1                          amd64        NVIDIA CUDA development files
ii  nvidia-cuda-doc                           5.0.35-7ubuntu1                          all          NVIDIA CUDA and OpenCL documentation
ii  nvidia-cuda-gdb                           5.0.35-7ubuntu1                          amd64        NVIDIA CUDA GDB
ii  nvidia-cuda-toolkit                       5.0.35-7ubuntu1                          amd64        NVIDIA CUDA toolkit
ii  nvidia-opencl-dev:amd64                   5.0.35-7ubuntu1                          amd64        NVIDIA OpenCL development files
ii  nvidia-profiler                           5.0.35-7ubuntu1                          amd64        NVIDIA Profiler for CUDA and OpenCL
ii  nvidia-settings-319-updates               319.60-0ubuntu1                          amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-visual-profiler                    5.0.35-7ubuntu1                          amd64        NVIDIA Visual Profiler


$ sudo apt-get install nvidia-current
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-current : Depends: xorg-video-abi-11 but it is not installable or
                           xorg-video-abi-12 but it is not installable or
                           xorg-video-abi-13 but it is not installable
                  Recommends: nvidia-settings-current but it is not installable
E: Unable to correct problems, you have held broken packages.


after making some more mess with drivers I reinstalled system (I found this option faster than playing with drivers), but still additional drivers tab is empty. Installing 'nvidia-319-updates' causes black screen after log in (with removed xorg.conf, with not removed i have extremely low resolution and also black screen)


black screen was caused bu this bug this bug. now it works, but 'nvidia-settings' are empty (but there is no information that I am not using nvidia drivers so I guess that they are ok) nvidia-settings

Also additional drivers tab is still empty: additional settings


Try installing:

sudo apt-get install nvidia-current

It should help.



sudo apt-get remove --purge nvidia-319-updates
sudo apt-get remove --purge nvidia-settings-319-updates
sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331

and reboot

  • I have updated my answer. I cannot install nvidia-current (unmet dependencies) – d21d3q Jan 8 '14 at 15:30
  • Did my solution work? – Frost Jan 8 '14 at 23:06
  • No, it didn't. See edit – d21d3q Jan 9 '14 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.