2

I can't copy any files from my Ubuntu (13.10) to Pendrive (Jetflash Transcend 8GB) When I try to copy a simple file, it says -

*Error While copying to "Transcend".
*The destination is read only

I tried both NTFS and FAT filesystem. As I am new to Ubuntu, tell me in detail.

2
  • What filesystem are you using on your flash drive? NTFS, FAT-32, etc. And how do you mount the drive? By command line, in fstab, in your GUI/file manager, etc. Please edit your question to include these details.
    – gertvdijk
    Jan 8, 2014 at 14:02
  • there is an Windows based solution described here: en.kioskea.net/forum/… this refers to Transcend's recovery tool and instructions.
    – user68186
    Jan 8, 2014 at 14:12

2 Answers 2

2

The following methods will often solve the problem and let you write to the pendrive.

If it does not work, there might be another problem, which can be analyzed as described in the following links

0

You probably have a hardware switch on your pendrive enabling read only access. It's usually marked with a little padlock or "lock" word.

Otherwise it may be an ownership issue. In terminal:

cd /media/your_username
ls -l

and check if you have owner status. If not:

sudo chown -R your_username pendrive_name

Replace your_username with your active user name, and pendrive_name with your pendrive name (found by ls command).

5
  • I donn't understand can you explain more easily....
    – bechitra
    Jan 8, 2014 at 14:02
  • Which part? Have you checked if you have a hardware switch on your pendrive? It may be just a little button on your pendrive case.
    – Frost
    Jan 8, 2014 at 14:12
  • I have checked my Pendrive and that is in FAT32 mode
    – bechitra
    Jan 8, 2014 at 14:35
  • The filesystem isn't the problem here. You are trying to copy via terminal or you are using Ubuntu built in file manager?
    – Frost
    Jan 8, 2014 at 15:04
  • Thanks a lot, it worked on a 32GB (ScanDisk USB 3.0) on UBUNTU 16.04 LTS
    – cpicanco
    May 3, 2017 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.