3

After 10 minutes my desktop computer darkens the screen, and when I move the mouse or tab any key it comes back alive and asks for my password. That is perfect and the behavior I like to have it.

But sometimes (mostly after a longer period) I can't get back to the login screen.

Nothing happens when moving mouse or press a key. Only way to get the computer back working is by restarting with reset button on the machine.

Has anyone an idea what I need to do?

I have a AMD HD 7950 grapics card with the 13.12 driver.

Ubuntu is 13.10 with Unity.

Here is a link to a blogger with the same problem:

Ubuntu Suspend Won't Wake Up: My Quest - wafflesatnoon.com

  • I'm not sure I understand your question. Do you want to avoid the 10min dark screens? Or the lockups? Disabling the darkening of the screen may help avoid the lockups. – landroni Jan 15 '14 at 21:02
  • landroni: I like the darkscreen and the lockups. But sometimes I dont't get the login back when i want it. Not by pressing any key and not by moving the mouse. The display(s) stay black. Nothing happens. I need to restart. – rechengehirn Jan 16 '14 at 4:43
  • What program is responsible for darkening the screen? XScreensaver? What DE do you use? – landroni Jan 16 '14 at 6:42
  • I don't know what programm is responsible. It's the standard programm from the settings panel. (Brightness and lock). What do you mean with DE? – rechengehirn Jan 16 '14 at 6:51
  • Desktop Environment (Unity, Xfce, KDE, etc.)? And can you open a taskmanager, monitor when new applications pop up, then open the "standard programm from the settings panel" and check which process popped dup in the taskmanager. – landroni Jan 16 '14 at 6:56
1

This bug in launchpad has some workaround which works for many users who have been using Ubuntu 13.10. Hope it works for you too.

Just follow these steps and try it once:

  1. Copy the grub file first as backup for safety:

    sudo cp /etc/default/grub /etc/default/grub_back
    

    taking the backup of original /etc/default/grub file, in case some error occurs we can get back to original state

  2. Open grub file to edit:

    sudo gedit /etc/default/grub
    

    opening the file in gedit to make the changes.

  3. Once file opened replace following line :

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    to the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"
    

    Note: The next line to the line mentioned above should be GRUB_CMDLINE_LINUX="" not GRUB_CMDLINE_LINUX="acpi_osi=Linux". Just check for the differences.

    save and close the file.

  4. Update the grub and restart your system once:

    sudo update-grub
    sudo reboot
    

Please reply if something goes wrong or you need any clarifications.

  • Thank you Kumar. I will try that and see if it happens again. This will take a while, because it not happens everytime. Thank you. – rechengehirn Jan 16 '14 at 13:32
  • @rechengehirn: yes of course. Now I'm also willing to know whether it works for you or not, since it worked for many users. :) – Saurav Kumar Jan 16 '14 at 14:01
  • Hi @Saurv Kumar. Today my computer didn't wakeup again. So this solution seems to be no help in my case. I have the feeling, that it has to do with usb. I try to add a non usb keyboard now. Perhaps that works. – rechengehirn Jan 18 '14 at 9:42
  • @rechengehirn: I just wanted to test whether it works for you or not. Never mind have you tried this answer? Actually I selected the best option which helped others and suggested you here. I just want from you to go for this answer of mine and check for other options. User's for whom it worked also replied with comment. :) – Saurav Kumar Jan 18 '14 at 9:46
-1

I had this same problem on my laptop. The only way I could come out of the screen dimmed state was to use the FN + "Screen" key on my laptop. In my case (on an Acer laptop), it was FN + F6. Strangely enough, it comes back on as soon as I hit the FN key, but it won't come on if I move the mouse, touch the touchpad, press any keys, etc. Pressing the FN key was the only thing that worked.

-2

Install the latest proprietary graphics driver on your PC.

At the moment to avoid restarts I would just disable the screen lock in the options.

PS: please give more details about your computer, OS version, graphics card, etc. The more the better

  • Hi Brask. I have a AMD HD 7950 grapics card with the 13.10 driver. – rechengehirn Jan 8 '14 at 13:12
  • Hi have now installed the amd 13.12 driver (Had to patch it for the 3.11.0-15-generic kernel. But still the same problem. – rechengehirn Jan 10 '14 at 7:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.