I have installed Ubuntu 12.04 LTS - 32 bit version on my system. I did sudo apt-get update && sudo apt-get upgrade. I installed the following packages -

  1. vim-gnome,

  2. python-matplotlib,

  3. python-scipy,

  4. acroread, and

  5. git.

I have a GPU on my machine: Nvidia GeForce GT 520. I wanted to install the CUDA Toolkit on this machine. For this, I have followed the instructions given in the webpage


I did what has been told there with few changes:

  1. In the step sudo apt-get install build-essential libopencv-dev linux-headers-uname -r(I dind't put uname -r in the appropriate quotes to maintain consistency), I have skipped the installation of libopencv-dev because I wanted to install OpenCV separately.

  2. I have downloaded the 32-bit version of CUDA Toolkit from https://developer.nvidia.com/cuda-downloads.

  3. I have stopped the lightdm service in the beginning of the installation using the command sudo service lightdm stop.

  4. The entire installation was done using the command prompt (CTRL-ALT-F1).

After this, when I tried to login from my account, I am unable to login. Though I am entering the correct password, it is returning me to the login screen. I have tried to do the following:

  1. Used the command sudo chown <myusername>:<myyusername> .Xauthority from the command prompt. But, it showed an error that Could not update ICE authority file /home/user/.ICEauthority

  2. So, I followed the procedure on Cannot login after update ubuntu 12.04 . ICEauthority error message. It still didn't work.

  3. I tried to remove the file /etc/modprobe.d/blacklist-nouveau.conf which was made during the installation as given above. I then updated: sudo update-initramfs -u

Waiting for an answer.

  • I am able to use the guest account. – rahul Jan 8 '14 at 12:09

I have found a solution to this problem.

A short and easy procedure to install CUDA Tool kit v5.5 in Ubuntu is given on this link: http://www.youtube.com/watch?v=lVzSullC9l8

If you have any version of CUDA, then run this command: /usr/bin/nvidia-uninstall. Then, proceed with the installation. The Xorg settings, and blacklisting drivers are automatically taken care of during the installation. I have followed this procedure and I could easily install CUDA on my machine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.