I can no longer mount an extra internal hard drive on my Ubuntu 11.04 64-bit system. I could up until a few days ago.

I think this has something to do with the problem ---- I had added a line at the end of fstab for the drive (/dev/sda) to automount, but I don't think it worked so I then removed the line from fstab. I think that I removed the line while the drive was mounted. The drive will no longer mount via GUI or CLI. At least I think the problem is related to this, it may not be at all.

Trying to mount:

$ sudo mount /dev/sda /media/openSpaceI 

(I realize this is not /dev/sda1 - I don't have an /dev/sda1)


enter image description here

That gives this error:

mount: wrong fs type, bad option, bad superblock on /dev/sda,
   missing codepage or helper program, or other error
   In some cases useful info is found in syslog - try
   dmesg | tail  or so


enter image description here

Here is the print out from dmesg | tail:

$ dmesg | tail
[ 9344.234380] compiz[6098]: segfault at 28 ip 00007f1fa0641335 sp 00007fff0b306700 error 4 in libregex.so[7f1fa063c000+8000]
[ 9987.879043] nautilus[6899]: segfault at 1505b817b60f ip 00007ff6eeefdb8d sp 00007fff09aa6170 error 4 in libgobject-2.0.so.0.2800.6[7ff6eeeca000+4e000]
[10001.231835] compiz[7360]: segfault at 28 ip 00007f38e0cfe335 sp 00007fff3228d380 error 4 in libregex.so[7f38e0cf9000+8000]
[10113.817592] compiz[7429]: segfault at 28 ip 00007f01c11cd335 sp 00007fffac4f4250 error 4 in libregex.so[7f01c11c8000+8000]
[10116.592022] compiz[7651]: segfault at 28 ip 00007f4369548335 sp 00007fffb3b2b030 error 4 in libregex.so[7f4369543000+8000]
[10117.958485] compiz[7666]: segfault at 28 ip 00007f3861d7d335 sp 00007fff268395d0 error 4 in libregex.so[7f3861d78000+8000]
[10366.207793] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)
[10855.975855] EXT4-fs (sdb): mounted filesystem with ordered data mode. Opts: (null)
[10863.666747] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)
[11125.922998] EXT4-fs (sda): bad geometry: block count 156282966 exceeds size of device (156282701 blocks)

My fstab file now:

enter image description here

I also ran disk utility on the disk. Disk is good and healthy. Here are the screenshots from that:

enter image description here

enter image description here

The drive contains no partitions and is formated to ext4 see - fdisk - enter image description here and e2fsck screen enter image description here you can see in the e2fsck.png that the filesystem size blocks differ by 265 from the physical size blocks if you do the math.

I'm bummed, I really don't want to have to wipe the data off this disk.

A funny thing I noticed is that the mount point (/media/openSpaceI) still remains. Usually after an unmount the directory disappears.

Any help getting this disk mounted would be extremely appreciated.



EDIT: Okay, I'm ready to give up. Is there a way I can see a list of anything on the disk before things went off the rails?



I really appreciate everyone who tried to help me out. I may try to make an image of the disk and work on it later. I move across the country the day after tomorrow.

  • There are some potential leads on this one here for those answering this question.
    – boehj
    May 5, 2011 at 3:16
  • Is it even possible to have a disk with a filesystem and no partitions? Are you sure you shouldn't be referring to /dev/sda1? I've never heard of not having any partitions, and my gut suggests that you have to have them, and that your disk must therefore have at least one partition. May 7, 2011 at 8:43
  • @mssever Here is a screenshot when I try to mount sda1 and sda- dl.dropbox.com/u/545099/sda1.png - also if you look at a comment I made on the next answer below I have listed 4 more screenshots from when I booted from a live cd with testdisk. May 7, 2011 at 16:53
  • In that case, I guess I'm stumped. May 8, 2011 at 3:23

1 Answer 1


Hmmm. Interesting problem you have, if you're telling us everything then Ubuntu somehow destroyed your filesystem during the course of mounting this disk. I find that hard to believe. It may be that the kernel has failed to discover the disk correctly and determined that the drive has less LBAs than in reality. It's tough to know exactly how much space should be there because you didn't create a partition. TIP in the future, even if you plan to span the entire disk, create a partition. At least then someone can examine the partition table and verify the boundaries.

EXTFS replicates the superblock several times over, we just need one to reconcile your partition.


Seems like it should point you in the right direction. I haven't recovered a filesystem in a while so I don't have any quick commands for you to run.

So your homework is to figure out how to get to your remaining superblocks and use them to reconcile the state of your filesystem. It would really help if you could post ALL of your logs somewhere and tell us the timestamp when things last worked, and when things started to go wrong.

Good Luck

  • I would love to post all the logs. Where can I look for those? I ran testdisk from a live cd but hardly knew what I was doing, I'll give it a shot again. May 5, 2011 at 3:03
  • @winchendonsprings - To access the logs, in a Live CD Ubuntu environment go to System > Administration > Log File Viewer.
    – boehj
    May 5, 2011 at 3:27
  • These can also be found in the same place in a non-Live CD (i.e. native) environment, in GNOME Classic at least. If you're running 11.04 you'll need to log out and log into a different session. I believe it's called 'GNOME Classic' but I could be wrong.
    – boehj
    May 5, 2011 at 3:36
  • I tried to figure out the values to run in the command from the end of the link you sent me. I couldn't figure it out. I think it's because there were no results at the end of the superblock test due to no partition. Maybe you can tell from the screenshot right above this comment. May 5, 2011 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.