12

I have just installed Steam on my 64-bit Ubuntu 13.10 and it works well and I can play games, but each time I launch it I get the following prompt:

Steam needs to install these additional packages: 
    libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
[sudo] password for user: 
............................................................................................................................................
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dri:i386 : Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not going to be installed
                        Depends: libdrm-nouveau2:i386 (>= 2.4.38) but it is not going to be installed
                        Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed
                        Depends: libdrm2:i386 (>= 2.4.38) but it is not going to be installed
                        Depends: libglapi-mesa:i386 but it is not going to be installed
 libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but it is not going to be installed
                        Depends: libglapi-mesa:i386 (= 9.2.1-1ubuntu3) but it is not going to be installed
                        Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not going to be installed
                        Depends: libxcb-dri2-0:i386 (>= 1.8) but it is not going to be installed
                        Depends: libxcb-glx0:i386 (>= 1.8) but it is not going to be installed
                        Depends: libxcb1:i386 but it is not going to be installed
                        Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
                        Depends: libxext6:i386 but it is not going to be installed
                        Depends: libxfixes3:i386 but it is not going to be installed
                        Depends: libxxf86vm1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Press return to continue: 

I have done the following :

sudo dpkg --add-architecture i386
sudo apt-get update

But no change whatsoever.

$ apt-cache policy libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
libgl1-mesa-dri:i386:
  Installed: (none)
  Candidate: 9.2.1-1ubuntu3
  Version table:
     9.2.1-1ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
libgl1-mesa-glx:i386:
  Installed: (none)
  Candidate: 9.2.1-1ubuntu3
  Version table:
     9.2.1-1ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages


$ sudo apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done

after sudo apt-get install aptitude && sudo aptitude install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

The following NEW packages will be installed:
  libdrm-intel1:i386{ab} libdrm-nouveau2:i386{ab} libdrm-radeon1:i386{ab} libdrm2:i386{ab} libelf1:i386{a} libexpat1:i386{a} libffi6:i386{a} libgl1-mesa-dri:i386{b} 
  libgl1-mesa-glx:i386{b} libglapi-mesa:i386{ab} libllvm3.3:i386{a} libpciaccess0:i386{a} libtxc-dxtn-s2tc0:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a} 
  libxcb-dri2-0:i386{ab} libxcb-glx0:i386{ab} libxcb1:i386{ab} libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxxf86vm1:i386{a} zlib1g:i386{a} 
0 packages upgraded, 25 newly installed, 0 to remove and 0 not upgraded.
Need to get 13,8 MB of archives. After unpacking 45,0 MB will be used.
The following packages have unmet dependencies:
 libxcb-dri2-0 : Breaks: libxcb-dri2-0:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed.
 libxcb-dri2-0:i386 : Breaks: libxcb-dri2-0 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed.
 libdrm-intel1 : Breaks: libdrm-intel1:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed.
 libdrm-intel1:i386 : Breaks: libdrm-intel1 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed.
 libgl1-mesa-dri : Breaks: libgl1-mesa-dri:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed.
 libgl1-mesa-dri:i386 : Breaks: libgl1-mesa-dri (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed.
 libdrm-radeon1 : Breaks: libdrm-radeon1:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed.
 libdrm-radeon1:i386 : Breaks: libdrm-radeon1 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed.
 libxcb1 : Breaks: libxcb1:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed.
 libxcb1:i386 : Breaks: libxcb1 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed.
 libglapi-mesa : Breaks: libglapi-mesa:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed.
 libglapi-mesa:i386 : Breaks: libglapi-mesa (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed.
 libxcb-glx0 : Breaks: libxcb-glx0:i386 (!= 1.10-1~xedgers~saucy1) but 1.9.1-3ubuntu1 is to be installed.
 libxcb-glx0:i386 : Breaks: libxcb-glx0 (!= 1.9.1-3ubuntu1) but 1.10-1~xedgers~saucy1 is installed.
 libgl1-mesa-glx : Breaks: libgl1-mesa-glx:i386 (!= 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy) but 9.2.1-1ubuntu3 is to be installed.
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 9.2.1-1ubuntu3) but 10.1.0~git20140102.5a51c1b0-0ubuntu0ricotz~saucy is installed.
 libdrm-nouveau2 : Breaks: libdrm-nouveau2:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed.
 libdrm-nouveau2:i386 : Breaks: libdrm-nouveau2 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed.
 libdrm2 : Breaks: libdrm2:i386 (!= 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy) but 2.4.46-1ubuntu1 is to be installed.
 libdrm2:i386 : Breaks: libdrm2 (!= 2.4.46-1ubuntu1) but 2.4.50+git20140102.e8cbc579-0ubuntu0ricotz~saucy is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                                                        
1)      gir1.2-totem-1.0                                                                    
2)      gnome-contacts                                                                      
3)      gnome-control-center                                                                
4)      gnome-control-center-datetime                                                       
5)      gnome-control-center-signon                                                         
6)      gnome-control-center-unity                                                          
7)      gstreamer1.0-clutter                                                                
8)      gstreamer1.0-plugins-bad                                                            
9)      indicator-bluetooth                                                                 
10)     libcheese-gtk23                                                                     
11)     libcheese7                                                                          
12)     libclutter-1.0-0                                                                    
13)     libclutter-gst-2.0-0                                                                
14)     libclutter-gtk-1.0-0                                                                
15)     libcogl-pango12                                                                     
16)     libcogl12                                                                           
17)     libegl1-mesa                                                                        
18)     libegl1-mesa-drivers                                                                
19)     libgbm1                                                                             
20)     libgl1-mesa-dri                                                                     
21)     libgstreamer-plugins-bad1.0-0                                                       
22)     libtotem0                                                                           
23)     libxatracker1                                                                       
24)     ubuntu-desktop                                                                      
25)     xorg                                                                                
26)     xserver-xorg-glamoregl                                                              
27)     xserver-xorg-video-all                                                              
28)     xserver-xorg-video-vmware                                                           

      Keep the following packages at their current version:                                 
29)     libdrm-intel1:i386 [Not Installed]                                                  
30)     libdrm-nouveau2:i386 [Not Installed]                                                
31)     libdrm-radeon1:i386 [Not Installed]                                                 
32)     libdrm2:i386 [Not Installed]                                                        
33)     libgl1-mesa-dri:i386 [Not Installed]                                                
34)     libgl1-mesa-glx:i386 [Not Installed]                                                
35)     libglapi-mesa:i386 [Not Installed]                                                  
36)     libx11-6:i386 [Not Installed]                                                       
37)     libxcb-dri2-0:i386 [Not Installed]                                                  
38)     libxcb-glx0:i386 [Not Installed]                                                    
39)     libxcb1:i386 [Not Installed]                                                        
40)     libxdamage1:i386 [Not Installed]                                                    
41)     libxext6:i386 [Not Installed]                                                       
42)     libxfixes3:i386 [Not Installed]                                                     
43)     libxxf86vm1:i386 [Not Installed]                                                    

      Leave the following dependencies unresolved:                                          
44)     gnome-bluetooth recommends gnome-control-center                                     
45)     indicator-power recommends gnome-control-center (>= 3.1) | ubuntu-system-settings   
46)     indicator-sound recommends gnome-control-center | ubuntu-system-settings            
47)     libaccount-plugin-1.0-0 recommends gnome-control-center-signon                      
48)     unity recommends gnome-control-center-unity                                         
49)     unity recommends indicator-bluetooth                                                
50)     xserver-xorg recommends libgl1-mesa-dri                                             
51)     ubuntu-restricted-addons recommends gstreamer1.0-plugins-bad                        
52)     gnome-control-center-data recommends gnome-control-center (>= 1:3.6.3-0ubuntu45.2)  
53)     indicator-datetime recommends gnome-control-center-datetime | ubuntu-system-settings
54)     xserver-xorg-core recommends libgl1-mesa-dri (>= 7.10.2-4)                          
55)     libgl1-mesa-glx recommends libgl1-mesa-dri (>= 7.2)                                 
56)     xserver-xorg-video-nouveau recommends libgl1-mesa-dri (>= 7.11.1)                   
57)     libegl1-mesa recommends libegl1-mesa-drivers                                        


Accept this solution? [Y/n/q/?] 

Those are my additionally installed PPAs:

./danielrichter2007-grub-customizer-saucy.list
./danielrichter2007-grub-customizer-saucy.list.save
./dropbox.list
./dropbox.list.save
./google-chrome.list
./google-chrome.list.save
./linrunner-tlp-saucy.list
./linrunner-tlp-saucy.list.save
./me-davidsansome-clementine-saucy.list
./me-davidsansome-clementine-saucy.list.save
./steam.list
./steam.list.save
./webupd8team-java-saucy.list
./webupd8team-java-saucy.list.save
6
  • @Braiam With this comma in between the package names then E: Unable to locate package libgl1-mesa-dri, without it I get the same output as in the question.
    – Patryk
    Commented Jan 9, 2014 at 0:56
  • @Braiam Ok, edited.
    – Patryk
    Commented Jan 9, 2014 at 11:26
  • What was the output of apt-cache policy libgl1-mesa-dri:i386 libgl1-mesa-glx:i386? Commented Jan 9, 2014 at 11:28
  • @AvinashRaj Updated :)
    – Patryk
    Commented Jan 9, 2014 at 11:56
  • select best server then sudo apt-get update and then try sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 Commented Jan 9, 2014 at 12:00

6 Answers 6

9

My answer is more for these issue which is marked as duplicated for this post. I'd installed blank new 14.04.2 64-bit and right then tried to install Steam client (dosn't matter from steampowered site or by apt-get install steam) In result it stucked with

Steam may not run:libGL.so.1

Steam needs to install these additional packages: 
libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
[sudo] password for numb: 
..............................
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
  libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
  unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                    Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

Well, I've tried a lot of things. But what had helped (thanks to this answer) was simple - just to install wanted libs with slightly different name:

sudo apt-get install libgl1-mesa-glx-lts-utopic:i386
1
  • I made a new clean install from 14.04.2 64bit exactly like you and had the same problem. Your solution helped perfectly, thank you. I haven't had the problem when I installed 14.04 the first time shortly after the release, which is strange for something that is called an LTS.
    – verpfeilt
    Commented May 8, 2015 at 20:49
4

Your problem is... that you are using a PPA. PPA packages aren't normally multiarch and you need multiarch. To solve this you should remove the PPA:

sudo rename 's/\.list$/.list.disable/' /etc/apt/sources.list.d/*.list
sudo apt-get update
sudo aptitude -f install libgl1-mesa-dri:i386=9.2.1-1ubuntu3 libgl1-mesa-glx:i386=9.2.1-1ubuntu3

That will solve the issue.

5
  • So what you suggest is to disable all of the PPAs that I use now and it should help ? I have edited my answer to with a list of added PPAs.
    – Patryk
    Commented Jan 11, 2014 at 19:10
  • 1
    Yes. If you see the error it says 1.10-1~xedgers~saucy1 breaks 1.9.1-3ubuntu1. The packages in multiarch needs all architectures with the same version. I'm betting that if you disable the x-edgers ppa, downgrade and try again everything is going to work.
    – Braiam
    Commented Jan 11, 2014 at 20:33
  • After I have properly downgraded the packages with sudo ppa-purge xorg-edgers then I am able to easily install all those packages.
    – Patryk
    Commented Jan 19, 2014 at 23:28
  • @Patryk I didn't remember that you need to specify the package version. This would have worked too. (and if you select N in aptitude until it got you the option to "downgrade" and install stuff ;))
    – Braiam
    Commented Jan 20, 2014 at 0:45
  • For some reason my libllvm9 was stuck in kisak and libg1-mesa-dri still depended on it (despite having been reinstalled on Ubuntu default repositories already), so I had to downgrade libllvm9 itself. Otherwise principle was the same, I disable (then purged) kisak's PPA. Also apt.llvm.org in the process, maybe I can put it back but default repo seem to have llvm-10 so that's enough for me now.
    – hsandt
    Commented Jul 6, 2020 at 23:05
2

@Braiam was right in his answer but I needed to properly downgrade the packages with ppa-purge

$ sudo ppa-purge xorg-edgers
1
  • The normal behavior is indeed downgrading, but be careful as it may remove packages in some circumstances... In my case, my packages were on kisak PPA and I did a blind sudo ppa-purge ppa:kisak/kisak-mesa (following their own instructions to uninstall). It removed all my related packages, including normal apps installed from default repositories. So always check your package removal warnings before confirming, and if downgrading is not automatic, downgrade by setting a specific version as Braiam said.
    – hsandt
    Commented Jul 6, 2020 at 23:03
2

I may be late for this but I recently updated my Pop!_OS 19.10 to 20.04 and encountered this issue.
My solution involves downgrading some packages and installing the remaining ones.

Steam installation: you can use any way (I am installing like this)

 sudo apt install steam

The error message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
steam:i386 : Depends: libgl1-mesa-dri:i386 (>= 17.3) but it is not going to be installed or
                   libtxc-dxtn0:i386 but it is not installable
          Depends: libgl1-mesa-glx:i386 but it is not going to be installed
          Recommends: mesa-vulkan-drivers:i386 but it is not going to be installed
          Recommends: mesa-vulkan-drivers:i386
E: Unable to correct problems, you have held broken packages.

This worked for me: first fully update all the packages

 sudo apt-get update -y && sudo apt-get upgrade -y

Now, use this to downgrade or install new packages

sudo apt-get install aptitude && sudo aptitude install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

We use aptitude to ensure that the installation will occur.

Firstly it will ask to keep packages as it is which we don't want so choose "n" press "enter" then choose the next solution "y" followed with an "enter". this will downgrade some packages and install some new packages.

Note: you can choose "?" option for more info.

Again try to install steam.

sudo apt install steam

and you are done. I hope this will help someone. peace.

1
  • Thanks for this. Installing steam on a recent reinstall of Ubuntu 20.04 (I guess after updating itself to 20.04.1) was going nowhere. Aptitude was able to resolve it for me with a number of downgrades. Commented Feb 16, 2021 at 2:54
0

Alternatively you can use

apt-cache madison <packagename>

to get list of versions available, then install particular previous version as

sudo apt-get install <packagename>=<version>
0

This finnaly worked for me:

for NVIDIA graphics:

apt-get install libgl1-nvidia-glx-i386

for ATI/AMD:

apt-get install libgl1-fglrx-glx-i386

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .