2

I'm experiencing a problem when trying to use a webcam with my USB 3.0 ports. I have no problem using the USB 2.0 ports.

I get the following error in guvcview or cheese:

libv4l2: error turning on stream: Invalid argument
VIDIOC_STREAMON - Unable to start capture: Invalid argument

I get a similar error in camorama:

libv4l2: error turning on stream: Invalid argument
libv4l2: error reading: Invalid argument

I've tried two different webcams (MS LifeCam HD-6000 and Logitech HD 615), and got the same result. Other devices seem work fine plugged into the USB 3.0 ports.

Does anyone know how what to try to get the webcams working with those ports?

-Thanks in advance

  • If you unplug the camera, run export LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so and plug it in again, does it work? – Seth Jan 7 '14 at 19:46
  • No, same result. – Greg Kramida Jan 7 '14 at 19:48
  • Try export LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so cheese – Seth Jan 7 '14 at 19:49
  • LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so cheese yields the same result. – Greg Kramida Jan 7 '14 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.