0

guys, I have a big problem ...
Whatever I want to do (at first I wanted reinstall php5), install, remove, upgrade, ... nothing works.

I got some error, I'm really stuck ... Here is some, when I try to upgrade:

root@preprod:/var/lib/mysql# aptitude safe-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
open: 33; closed: 4991; defer: 9204; conflict: 2                                                                                                 oThe following packages have unmet dependencies:
  fglrx: Depends: xserver-xorg-core but it is not installable
         Depends: dkms but it is not installable

Then I tried to install xserver-xorg-core:

root@preprod:/var/lib/mysql# apt-get install xserver-xorg-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  cpp-4.4 g++-4.4 gcc-4.4 gcc-4.4-base gcc-4.6-base ifupdown initramfs-tools initramfs-tools-bin initscripts keyboard-configuration lib32gcc1
  libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libdrm-nouveau1a libffi6 libgcc1 libgfortran3 libgl1-mesa-dri libgmp10 libgomp1 libllvm3.0
  libmpfr4 libnih-dbus1 libnih1 libplymouth2 libquadmath0 libstdc++6 libstdc++6-4.4-dev libtinfo5 locales mountall plymouth
  plymouth-theme-ubuntu-text upstart
Suggested packages:
  gcc-4.4-locales g++-4.4-multilib gcc-4.4-doc libstdc++6-4.4-dbg gcc-4.4-multilib libmudflap0-4.4-dev libgcc1-dbg libgomp1-dbg libmudflap0-dbg
  libcloog-ppl0 libppl-c2 libppl7 rdnssd glibc-doc libglide3 libstdc++6-4.4-doc graphviz xfonts-100dpi xfonts-75dpi xfonts-scalable
The following packages will be REMOVED:
  fglrx libdrm-nouveau1
The following NEW packages will be installed:
  gcc-4.6-base initramfs-tools keyboard-configuration libdrm-nouveau1a libffi6 libgmp10 libllvm3.0 libnih-dbus1 libquadmath0 libtinfo5 mountall
  plymouth plymouth-theme-ubuntu-text upstart xserver-xorg-core
The following packages will be upgraded:
  cpp-4.4 g++-4.4 gcc-4.4 gcc-4.4-base ifupdown initramfs-tools-bin initscripts lib32gcc1 libc-bin libc-dev-bin libc6 libc6-dev libc6-i386
  libgcc1 libgfortran3 libgl1-mesa-dri libgomp1 libmpfr4 libnih1 libplymouth2 libstdc++6 libstdc++6-4.4-dev locales
23 upgraded, 15 newly installed, 2 to remove and 283 not upgraded.
2 not fully installed or removed.
Need to get 0B/45.3MB of archives.
After this operation, 90.6MB disk space will be freed.

But i got this error:
E: Could not perform immediate configuration on 'plymouth'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

There are errors anywhere ... I'm on Ubuntu 10.04 TLS

0

Have you tried to remove the package directly with apt-get? Your question is tagged with the server tag, so on a server the fglrx package is normally not needed:

apt-get remove fglrx

Alternativily you can try the fix-broken option of apt-get:

apt-get install -f

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.