I've just installed a clean version of 11.04 and I am trying to get the NVIDIA driver to work.

Just after installing I've seen Unity and used it. Then I activated the NVIDIA driver (from the additional drivers dialog) or I just restarted (I don't remember well anymore) and I got a message telling me that Unity didn't want and I got into classic mode.

In the additional drivers dialog it says the NVIDIA driver is "activated but not currently in use". I found out that I should do a sudo nvidia-xconfig, which gave back:

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf. Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup' New X configuration file written to '/etc/X11/xorg.conf'

(Exactly as posted on the ubuntuforums before. I also have the same version, "nvidia-xconfig: version 270.41.06".)

After I reboot I can see the Ubuntu logo bith the four dots starting up and then only a console with some starting messages:

  • Starting ACPI deamon [ OK ]

.. more of such starting messages ..

modem-manager[778]: ModemManager (version 0.4) starting...

.. and more modem-manager loading plugin messages ..

.. and ending with:

  • Stopping Flush boot log to disk [ OK ] Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox

[ OK ]

And then nothing happens anymore. I stay in this console and can't get into a graphical mode in a normal way.

I can reboot in recovery mode and start a classic GUI, replace the xorg.conf with the backuped one and have everything working again. And thus also repeat this whole process over and over again. But the NVIDIA driver is still "not currently in use".

Anyone knowing a next hint to help me further?

  • I have the same problem after I upgraded to 11.04. Both motherboard and grphic card are NVIDIA so I cannot do anything. It has been 5 month since the original question was posted but there is no fix yet? – user28636 Oct 18 '11 at 12:39
  • @shoon, look at the answers. At least it is known. And there are some solutions in the accepted answer. – Lode Oct 20 '11 at 6:16

I found out that the problem is my laptop having a NVIDIA Optimus card, making it impossible to use it and be able to get Unity..

Though I also found this thread that says that this guy solved it and now has an automatic process called prime-ng bumblebee. But I haven't tried it out yet.

Update: by now there are two (competing) projects: ironhide (from the original author of bumblebee) and Bumblebee-Project (spin-off/continuation of the original bumblebee).

  • Correction: Ironhide is a continuation of the original Bumblebee code (it just does not support other distros anymore), Bumblebee from the Bumblebee Project is completely rewritten for better stability. See also askubuntu.com/q/36930/6969 – Lekensteyn Oct 20 '11 at 8:08

It perhaps is a bug but to write an xorg.config file you need to be root i.e. use sudo the nvidia script dosn't always prompt for root password and therefore can't write the file.
One way to do this is boot to recovery mode from grub and update nvidia configuration from there.

Not the answer you're looking for? Browse other questions tagged or ask your own question.