3

When trying to launch Audacity, I get the following error:

Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog.

  • No files or folder have been moved.
  • I have purged Audacity, deleted any files, etc manually and re-installed

In terminal:

pst007x@pst007x-Serval-Professional:~$ audacity 

(process:16390): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(process:16390): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(process:16390): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(process:16390): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

** (Audacity:16390): WARNING **: Owner of /tmp/orbit-pst007x is not the current user

Segmentation fault
pst007x@pst007x-Serval-Professional:~$
  • I have not changed any users or added any additional users.
  • All privaleges, etc are default.

Ubuntu 13.10 64bit (all updates applied)

ADDITIONAL:

I can open as gksu audacity

So it looks like privileges is an issue somewhere. I have checked all privileges and all seems ok, but clearly not....

I tried changing the Directory in Preferences to a directory in my home folder:

/home/pst007x/Music/audacity_temp/

but when starting again (not in root) same error...

Any ideas what files could be lacking privileges?

After changing the Directory, when running I get this:

pst007x@pst007x-Serval-Professional:~$ audacity 

(process:28364): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(process:28364): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(process:28364): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(process:28364): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
Segmentation fault
pst007x@pst007x-Serval-Professional:~$ 

I checked installed files using Synaptic Package Manager, then checked permissions:

pst007x@pst007x-Serval-Professional:~$ sudo chmod -R 777 /usr
[sudo] password for pst007x: 
pst007x@pst007x-Serval-Professional:~$ audacity

(process:31026): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(process:31026): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(process:31026): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(process:31026): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
Segmentation fault
pst007x@pst007x-Serval-Professional:~$ 

EDIT. After the above, I rebooted and was no longer able to login. So I did a fresh install. Not a bad thing since the original install on the this system was 10.10. Working ok after fresh install.

Thank you for taking the time to post answers and suggestions..

5
  • You have tried rebooting? ;-)
    – Wilf
    Jan 6, 2014 at 21:06
  • 1
    If you log in as another user (not root) do you still have this problem? if not, what's the differences in permission settings?
    – virtualxtc
    Jan 6, 2014 at 21:38
  • 1
    Is your hard drive or /home partition full?
    – Panther
    Jan 6, 2014 at 21:39
  • Thanks.. for the suggestions. The system would not reboot after I changed the permissions for some reason... So I did a fresh install. Thanks again for the help.. appreciated..
    – pst007x
    Jan 12, 2014 at 0:25
  • Installing via snap package manager does not work in ubuntu, you have to use apt
    – Jonathan
    Oct 12, 2018 at 16:34

4 Answers 4

5

I am using Audacity v2.0.3 on Linux Mint 16 which is a derivative of Ubuntu 13.10 and was having the same problem.

When Audacity starts up, it looks for a temporary directory to store its temporary files, namely

/var/tmp/audacity-${USER}

where ${USER} has the value of the login username, and the USER environmental variable is usually correctly set during the login process.

To be sure, one can always do

echo ${USER}

to see if it is set and set to the appropriate value.

So the very simple solution is

mkdir /var/tmp/audacity-${USER}

and for privacy, if desired and if your umask is other than 0007,

chmod 0700 /var/tmp/audacity-${USER}

or you could do it in one go with

mkdir -m 0700 /var/tmp/audacity-${USER}

Obviously the user has to have write permission on /var/tmp, otherwise this will need to be done by root who will also have to change the user and group ownership of the created directory to the appropriate user and group.

Why audacity does not create this directory for its-self is a question which should be directed at the writers of the audacity, because popping up a dialog to say that some unamed directory for temporary storage does not exist and then segfaulting is an extremely bad user experience.

The suggestion that one should re-install an operating from scratch just to solve the problem of a missing directory is an unacceptable answer.

4
  • mkdir /var/tmp/audacity-${USER} solved my issue, thanks. I hope that at some point more people don't accept "reinstall everything" as a solution for every single issue. Mar 8, 2018 at 15:09
  • In Ubuntu 18.04, Mine still won't open, says it can't lock. Not sure if this CLI error is related ERROR: ld.so: object 'libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (failed to map segment from shared object): ignored.
    – Jonathan
    Oct 12, 2018 at 16:29
  • @Jonathan You will need root-privileges to create /var/tmp/audacity-${USER} and after creation this directory will be owned by root. You have to make use of sudo chown ${USER}: /var/tmp/audacity-${USER}. The answer above is incomplete.
    – mook765
    Oct 12, 2018 at 16:52
  • Yeah I tried that, and it didn't work. The problem was that when audacity is installed with snap install instead of apt install it never will work
    – Jonathan
    Oct 12, 2018 at 20:54
1

I had the same problem with under cinnamon Linux mint 17.1. Solved it by reinstalling audacity after deleting /home/your_username/.audacity-data directory and that fixed the problem

2
  • I use Ubuntu Studio 16.04 LTS and I had the same problem. I fixed it eliminating the "/home/my_username/.audacity-data" folder. Of course, I lost all the visual preferences of the Audacity appearance, but it works so fine!!!
    – Juan
    Oct 25, 2016 at 6:07
  • Removing this directory solve that in UBUNTU 16.04 LTS, sudo rm -R /home/your-user-name/.audacity-data
    – EsmaeelE
    Feb 10, 2019 at 23:42
0

I built audacity from the latest SVN source, and it segfaults while trying to load /usr/lib/ladspa/blop_files/parabola_1649_data.so. I found that out by starting it from inside gdb:

gdb /usr/local/bin/audacity
run
....
<segfault happens>
bt

Uninstalling the blop package fixed it for me. IDK why, because the ubuntu-packaged /usr/bin/audacity doesn't have a problem even with blop installed.

-2

Not really an answer, but a solution, because, I was no longer able to reboot after altering permissions, I decided on a fresh install.

So I booted in on a live disk, made backups, and reinstalled the OS.

Turned out to be the easiest solution, very easy to restore most settings, just by copying over the appropriate backed-up files into the new system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .