0

I installed ubuntu 13.10 from a bootable live usb stick into a new 2tb usb hdd. The drive came with a 100mb "raw" partition and a ntfs one. I deleted the ntfs and created an ext4 and swap (sde3 and sde5). Installation completed successfully but when trying to boot from the usb hdd, grub starts as expected but soon enters rescue mode. I've read some questions here and some forum topics but cant figure out this....

boot-repair output just in case http://paste.ubuntu.com/6705167/

The usb drive is dev/sde. I have a lot a hdds and a fake raid but don't bother looking at them, pretend my pc has no internal drives. All I want is to be able to have a "non-live" bootable ubuntu on a external drive's partition.

Thx in advance.

ps: already seen links https://askubuntu.com/questions/282512/how-to-move-ubuntu-12-04lts-from-usb-to-hdd Why can't I boot from portable HD? Can I install ubuntu to a partition on my portable hard drive? HELP! Booting Ubuntu off Portable HDD, lots of issues with GRUB

  • It appears you are using RAID, or at least you have a ton of RAID errors. Fix any hardware RAID first. Then, to boot RAID you need a separate /boot partition, outside of the RAID array. – Panther Jan 6 '14 at 20:36
  • Thx for the answer but as I said. I dont want to boot from the fake raid, thats a different story. Just pretend my pc has no internal hdd and all I want is to be able to install and boot from an external one. – TigerShark Jan 6 '14 at 20:52
  • It'd help if you know which dev your HDD is identified. During the installation, it usually will ask you whether you want to install GRUB on master hdd - which usually is /dev/sda by default and load GRUB in /dev/sda1. If your external hdd is /dev/sdb or /dev/sdc or such, instruct it'll install GRUB on that. – Faron Jan 6 '14 at 21:02
  • Again, thx for the answer but as I said. The usb drive is /dev/SDE and during install I pointed to it for grub installation. – TigerShark Jan 6 '14 at 21:06
  • in that case, /dev/sde1 is the place where GRUB should be in. If it still doesn't work, then I do not think it may be GRUB issue, but fstab issue? fstab is what controls the HDD mounting - maybe check into that? – Faron Jan 6 '14 at 21:15
0

Line 580 is not showing your files.Normally Boot-Repair sees them and then when far on drive like yours must be gives a warning about far from start of drive. Some combination of BIOS and particularly USB large drives have issues with boot files being far into drive. There was a fixed bug on very large / (root) partitions, but there still issues. Best to create a small 10 to 25GB / (root) or even smaller 500MB /boot totally within the first 100GB of an external drive.

  • Interesting, I'll try that. If that was the actual problem, I'll hit some people on the head for such a horrible bug :P – TigerShark Jan 6 '14 at 21:08
  • It worked out although I had to create 2 partitions. One of about 100Mb without formatting at the beginning of the disk and the ext4 ubuntu one right after it. Without the first partition it wouldn't work. This is ridiculous, a REALLY BIG warning should be displayed EVERY time you install ubuntu/grub, either gui or console..... – TigerShark Jan 7 '14 at 14:42
  • It seems to only be some BIOS that have the issue. Not sure if USB driver or grub issue, but you should file bug report or search and see if one exists. Also was drive gpt partitioned? That needs the bios_grub unformatted partition but usually 1 or 2 MB. – oldfred Jan 7 '14 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.