I have Ubuntu 12.04 installed on my machine (Dual boot). It was working fine till today. I executed the following commands in the terminal, and when I restarted I get a Purple Screen of Death.

sudo apt-get autoremove

I also had Qt Designer installed, so I removed it using

sudo apt-get remove qt4-dev-tools
sudo apt-get remove qt4-docs
sudo apt-get remove qt4-assistant
sudo apt-get remove qt4-linguist

I had already tried the following:

  1. In recovery mode, it always hangs at this part.

    * Starting MySQL server [OK]
  2. From a Ubuntu Forum post, I tried doing Ctrl+Alt+F1 and then

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install fglrx
    sudo aticonfig --initial

But this always ends with aticonfig:No supported adapters detected.

Any help would be greatly appreciated.

P.S : Please do not mark this as duplicate as I've gone through many threads and I'm not able to find a solution myself.

EDIT: it now hangs at Checking battery state itself :( . I've referred to this http://ubuntuforums.org/showthread.php?t=1606130 but I'm unable to find any solution.

  • Suggest you visit askubuntu.com/questions/162075/… – K7AAY Jan 6 '14 at 19:33
  • 1
    Edit your boot parameters in grub (press e then look for the line ending in quiet splash) remove quiet splash and write verbose. Then try booting your system again. – Braiam Jan 8 '14 at 1:36

If it is hanging at * Starting MySQL server [OK] you should try disabling MySQL server (via Ctrl+Alt+F1) and then see if it continues past that stage when you reboot.

You can do this as follows:

sudo nano /etc/init/mysql.conf

Comment out (using a hash sign) the start on section - and this section only! If it spans multiple lines, add a hash sign to each line.

For example:

#start on (net-device-up
          #and local-filesystems
          #and runlevel [2345])

Instructions from: How to keep apache and mysql from starting automatically

| improve this answer | |
  • Ummm.. How do I do that? – Manoj Jan 6 '14 at 20:11
  • Thanks, I tried that but now it hangs before. I've edited my question. :( – Manoj Jan 6 '14 at 21:02
  • Hmmm, I'm out of ideas then, sorry. Hopefully someone else comes along with more knowledge than me. – Jet86 Jan 7 '14 at 2:36

To restore your ubuntu 12.04 do a version upgrade to Ubuntu 12.10 via USB and you will have the problem fixed.

You could also do a clean install of the latest 13.10 to avoid any future problems as it is the most updated stable version for Ubuntu and as you are not an Enterprise you don´t need LTS versions.

PS: if you boot into the system run the following on the terminal:

sudo apt-get update

sudo apt-get -f upgrade

sudo apt-get -f dist-upgrade (this last one doesn´t update your system to a new Ubuntu verison)

Hope it helped you out.

| improve this answer | |
  • 2
    They don't have to upgrade to 12.10 just to fix this. This answer is incorrect, however it is still an attempt at an answer. – Thomas Ward Jan 8 '14 at 2:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.