0

Recently I removed Mono Develop . After that every time when I install new packages it show's me the below message . I tried sudo apt-get install -f but it didn't work . How fix it ?

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
13 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up gconf2 (3.2.5-0ubuntu2) ...
/usr/share/gconf/schemas/desktop_gnome_url_handlers.schemas:105: parser error : Premature end of data in tag locale line 102

 ^
/usr/share/gconf/schemas/desktop_gnome_url_handlers.schemas:105: parser error : Premature end of data in tag schema line 95

 ^
/usr/share/gconf/schemas/desktop_gnome_url_handlers.schemas:105: parser error : Premature end of data in tag schemalist line 3

 ^
/usr/share/gconf/schemas/desktop_gnome_url_handlers.schemas:105: parser error : Premature end of data in tag gconfschemafile line 2

 ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas:132: parser error : Premature end of data in tag long line 132
        <long>File name of the bell s
                                     ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas:132: parser error : Premature end of data in tag locale line 130
        <long>File name of the bell s
                                     ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas:132: parser error : Premature end of data in tag schema line 124
        <long>File name of the bell s
                                     ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas:132: parser error : Premature end of data in tag schemalist line 3
        <long>File name of the bell s
                                     ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas:132: parser error : Premature end of data in tag gconfschemafile line 2
        <long>File name of the bell s
                                     ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_mouse.schemas:117: parser error : Premature end of data in tag key line 117
      <key>/schemas/desktop/gnom
                                ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_mouse.schemas:117: parser error : Premature end of data in tag schema line 116
      <key>/schemas/desktop/gnom
                                ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_mouse.schemas:117: parser error : Premature end of data in tag schemalist line 3
      <key>/schemas/desktop/gnom
                                ^
/usr/share/gconf/schemas/desktop_gnome_peripherals_mouse.schemas:117: parser error : Premature end of data in tag gconfschemafile line 2
      <key>/schemas/desktop/gnom
                                ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : expected '>'
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : Opening and ending tag mismatch: short line 113 and shor
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : Premature end of data in tag locale line 112
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : Premature end of data in tag schema line 105
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : Premature end of data in tag schemalist line 3
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/system_http_proxy.schemas:113: parser error : Premature end of data in tag gconfschemafile line 2
        <short>Proxy configuration mode</shor
                                             ^
/usr/share/gconf/schemas/desktop_gnome_lockdown.schemas:119: parser error : Premature end of data in tag applyto line 119
      <applyto>/desktop/gnome/lockdown/disable_applicatio
                                                         ^
/usr/share/gconf/schemas/desktop_gnome_lockdown.schemas:119: parser error : Premature end of data in tag schema line 117
      <applyto>/desktop/gnome/lockdown/disable_applicatio
                                                         ^
/usr/share/gconf/schemas/desktop_gnome_lockdown.schemas:119: parser error : Premature end of data in tag schemalist line 3
      <applyto>/desktop/gnome/lockdown/disable_applicatio
                                                         ^
/usr/share/gconf/schemas/desktop_gnome_lockdown.schemas:119: parser error : Premature end of data in tag gconfschemafile line 2
      <applyto>/desktop/gnome/lockdown/disable_applicatio
                                                         ^
/usr/share/gconf/schemas/desktop_gnome_interface.schemas:115: parser error : expected '>'
      <owner>gnome</o
                     ^
/usr/share/gconf/schemas/desktop_gnome_interface.schemas:115: parser error : Opening and ending tag mismatch: owner line 115 and o
      <owner>gnome</o
                     ^
/usr/share/gconf/schemas/desktop_gnome_interface.schemas:115: parser error : Premature end of data in tag schema line 112
      <owner>gnome</o
                     ^
/usr/share/gconf/schemas/desktop_gnome_interface.schemas:115: parser error : Premature end of data in tag schemalist line 3
      <owner>gnome</o
                     ^
/usr/share/gconf/schemas/desktop_gnome_interface.schemas:115: parser error : Premature end of data in tag gconfschemafile line 2
      <owner>gnome</o
                     ^
/usr/share/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas:127: parser error : Premature end of data in tag gettext_domain line 127
              <gettext_domain>libgnome-
                                       ^
/usr/share/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas:127: parser error : Premature end of data in tag schema line 121
              <gettext_domain>libgnome-
                                       ^
/usr/share/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas:127: parser error : Premature end of data in tag schemalist line 3
              <gettext_domain>libgnome-
                                       ^
/usr/share/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas:127: parser error : Premature end of data in tag gconfschemafile line 2
              <gettext_domain>libgnome-
                                       ^
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libgnomevfs2-common:
 libgnomevfs2-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnomevfs2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomevfs2-0:
 libgnomevfs2-0 depends on libgnomevfs2-common (>= 1:2.24); however:
  Package libgnomevfs2-common is not configured yet.
 libgnomevfs2-0 depends on libgnomevfs2-common (<< 1:2.25); however:
  Package libgnomevfs2-common is not configured yet.
dpkg: error processing libgnomevfs2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-common:
 libgnome2-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libgnome2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libNo apport report written because the error message indicates its a followup error from a previous failure.
                                                               No apport report written because the error message indicates its a followup error from a previous failure.
                                                                        No apport report written because MaxReports is reached already
                                     No apport report written because MaxReports is reached already
  No apport report written because MaxReports is reached already
                                                                No apport report written because MaxReports is reached already
                             No apport report written because MaxReports is reached already
                                                                                           No apport report written because MaxReports is reached already
                                                        No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   gnome2-0:
 libgnome2-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
 libgnome2-0 depends on libgnome2-common (>= 2.32); however:
  Package libgnome2-common is not configured yet.
 libgnome2-0 depends on libgnome2-common (<< 2.33); however:
  Package libgnome2-common is not configured yet.
dpkg: error processing libgnome2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbonoboui2-0:
 libbonoboui2-0 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libbonoboui2-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomeui-0:
 libgnomeui-0 depends on libbonoboui2-0 (>= 2.15.1); however:
  Package libbonoboui2-0 is not configured yet.
 libgnomeui-0 depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
 libgnomeui-0 depends on libgnomevfs2-0 (>= 1:2.17.90); however:
  Package libgnomevfs2-0 is not configured yet.
dpkg: error processing libgnomeui-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcanberra-gtk-module:i386:
 libcanberra-gtk-module:i386 depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing libcanberra-gtk-module:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:i386:
 ia32-libs-multiarch:i386 depends on libcanberra-gtk-module; however:
  Package libcanberra-gtk-module:i386 is not configured yet.
dpkg: error processing ia32-libs-multiarch:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs:
 ia32-libs depends on ia32-libs-multiarch; however:
  Package ia32-libs-multiarch is not installed.
  Package ia32-libs-multiarch:i386 is not configured yet.
dpkg: error processing ia32-libs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of metacity-common:
 metacity-common depends on gconf2 (>= 2.28.1-2); however:
  Package gconf2 is not configured yet.
dpkg: error processing metacity-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmetacity-private0:
 libmetacity-private0 depends on metacity-common (>= 1:2.34); however:
  Package metacity-common is not configured yet.
 libmetacity-private0 depends on metacity-common (<< 1:2.35); however:
  Package metacity-common is not configured yet.
dpkg: error processing libmetacity-private0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome2-bin:
 libgnome2-bin depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not configured yet.
dpkg: error processing libgnome2-bin (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gconf2
 libgnomevfs2-common
 libgnomevfs2-0
 libgnome2-common
 libgnome2-0
 libbonoboui2-0
 libgnomeui-0
 libcanberra-gtk-module:i386
 ia32-libs-multiarch:i386
 ia32-libs
 metacity-common
 libmetacity-private0
 libgnome2-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)
0
0

Possible duplicate of that question: I encountered a gconf2 error while installing some packages, what should I do?

Answer is:

Have you tried sudo dpkg-reconfigure gconf2? If that doesn't work, try sudo apt-get remove --purge gconf2 && sudo apt-get install gconf2.

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.