1

This question is a somewhat prologue to a different question posted (here). As I can state that I can send email from my Ubuntu server (12.04) via Roundcube, perfectly. However, I cannot manage to correctly configure my desktop email client on my Mac. And I feel the problem lies in the SMTP port.

However, I want to know where I should be debugging. Therefore I want to know: If I can send emails from the server, via Roundcube, can I state that the SMTP server/postfix is correctly installed/configured/working?

Edit: Just found this information, which made help:

Starting Nmap 5.21 ( http://nmap.org ) at 2014-01-06 15:50 CET

Nmap scan report for localhost (127.0.0.1)

Host is up (0.0000060s latency).

Not shown: 993 closed ports

PORT STATE SERVICE

21/tcp open ftp

22/tcp open ssh

53/tcp open domain

80/tcp open http

110/tcp open pop3

143/tcp open imap

3306/tcp open mysql

sudo netstat -tlnp root@vps:~# sudo netstat -tlnp Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 2550/master
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 779/mysqld
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 758/dovecot
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 758/dovecot
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 1002/apache2
tcp 0 0 159.253.1.196:53 0.0.0.0:* LISTEN 744/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 744/named
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 665/sshd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2550/master
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 744/named
tcp 0 0 0.0.0.0:4190 0.0.0.0:* LISTEN 758/dovecot
tcp6 0 0 :::21 :::* LISTEN 946/proftpd: (accep tcp6 0 0 :::22 :::* LISTEN 665/sshd
tcp6 0 0 :::25 :::* LISTEN 2550/master

  • None of the typical SMTP ports (25, 587, 465) seem to be open and listening, so the host you scanned does not provide any kind of SMTP service on localhost interface. If the service is not available on external interface(s), I would say that the SMTP server is not properly configured. – taneli Jan 6 '14 at 15:20
  • can you add the output of sudo netstat -tlnp – squareborg Jan 6 '14 at 15:21
  • I guess you're looking for this tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2550/master or tcp6 0 0 :::25 :::* LISTEN 2550/master complete list posted in main post – Sander Schaeffer Jan 6 '14 at 15:24
  • What error(s) were reported by the MUA clients when trying to configure them to use your server? It appears that SMTP is listening to port 25 on IPv4 and IPv6. Most likely problem is Postfix configuration for SMPTauth. – douggro Jan 6 '14 at 15:57
  • While configuring Airmail, it said 'A stable connection to the server could not be established.', while I could configure it in Apple Mail (which does not check the configuration, apparently), it says "The server mail.MYDOMAIN.nl has a connection via the default gateways rejected (Default gateways = 25,467, 587 ) – Sander Schaeffer Jan 6 '14 at 16:08
0

Yes! I'm so glad this issue has been fixed! After a lot of googling, I found the solution myself. However, many steps need to have been taken!

postfix should be configured well. Gladly I had a second VPS with correct postfix configuration (which I completely forgot) - This one doesn't have a correct configuration either, though. Time to fix that.

Apparantly, after a lot of sudo mmap <server ip> and using telnet <port number> plus googling to port 25, I found out that port 25 is blocked by my ISP. Or.. I think so.

Therefor, I went into the Postfix master file (sudo nano /etc/postfix/master.cf) and pasted this line submission inet n - n - - smtpd within the file. This opens Postfix on port 587 and will have Postfix use port 587 instead of port 25.

After that, just enable port 587 in your server firewall (sudo ufw allow 587) and after checking with my desktop mail client, I can verify: It's working!

If anyone has an issue like this, just open chat / comment or something. I'd like to help. However: My skills are equal to your grandmother's skills with computers, so don't expect much: Though, I managed to fix this... =)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.