I am using ubuntu 13.10.I cant able to use backspace in terminal. While using backspace it just passed through the letters.Please help me...

The cursor has got 2 states. One looks like a box and the other is an under score. It seems the current state of yours is the box. Simply press the Ins key (Insert key) in your keyboard and the cursor transforms into a line. It should work as normal.

P.S: The Insert key is a keyboard key located on the majority of all computers that allows text to be inserted. When insert is enabled, the text inserted in a document will not overwrite any other text. However, when disabled, text will be overwritten.

You can change this behavior by editing the terminal profile.

  1. Go Profile Preferences, either by:

    Right-clicking in the terminal window and choosing Profiles >> Profiles Preferences

    Or from the menu: Edit >> Profile Preferences

  2. Go the the compatibility tab

  3. Find Backspace key generates
  4. Select ASCII DEL

This should solve your problem.

If by "passed through the letters" you mean the cursor goes back over top of the previous character without removing it, then your computer simply can't render the terminal properly. If you type a letter after that, it should replace the letter it was hovering over.

The problem should be resolved by closing (or logging out) of the terminal and opening (or logging back in to) the terminal.

The only other option I can think of is somehow your keyboard layout is incorrect and thinks that the backspace key is the left arrow key.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.