0

This question already has an answer here:

So, just today I installed Lubuntu 13.10 on my piece-of-crap laptop and I absolutely LOVE how fast it is. I installed Java 7 successfully, and I downloaded the Minecraft.jar (Minecraft fo Linux/Other) files at https://www.minecraft.net/download. The first thing I did was drag the Minecraft.jar to my desktop. I then right-clicked it, went to properties, made sure it was marked as executable, and then selected "open with..." but I didn't find Java 7 Runtime Environment nor anything Java-related. I then tried running it via terminal (I forgot the command but I believe it went along the lines of "java -jar minecraft.jar"). I also tried using "sudo chmod a+x minecraft.jar" to ensure that it was indeed executable. Yet none of this worked. Any help is appreciated. Thanks! ^-^

--------------------Devon

-EDIT- Should I just switch to a distribution that I know can run Minecraft?

marked as duplicate by Seth, karel, Radu Rădeanu, falconer, Florian Diesch Jan 6 '14 at 21:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Okay, so I found what the problem could [possibly] be, and that is that although the file NAME is Minecraft.jar, the file TYPE is still considered a .zip. Anyone know how to convert the file? – battleof3 Jan 6 '14 at 1:06
0

In my memory, most people I know use OpenJDK Java 6 Runtime to run Minecraft because it doesn't work with OpenJDK 7, but it works well with OpenJDK Java 7 Runtime for me. Try to right click → PropertiesOpen withOpenJDK Java 6 RuntimeSet as default.

  • I installed Java 7 Runtime Environment. When I had Ubuntu 13.10 on this same laptop, it worked fine. I just installed Lubuntu 13.10 on my laptop because it's a very low-end laptop. – battleof3 Jan 6 '14 at 0:35
0

Type

java -version

into the terminal (Ctrl + Alt + T)

to see if java is infact installed. If it is not type

sudo apt-get install openjdk-7-jre

And you should be set

  • I already said that I do indeed have java installed. It's just that whenever I right-click the Minecraft.jar file and go to "open with..." it does not include anything that has to do with java. – battleof3 Jan 6 '14 at 0:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.