0

I am using Ubuntu 12.10 64bit on a 4 month old manufacturer constructed Gateway PC bought from best buy.

The screen has gone dark and this error appears on the screen:

[509156.065626] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[509156.070291] [drm:i915_write32] *ERROR* Unknown unclaimed register before writing TO 220a8
[509165.087235] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung

Screenshot: enter image description here

The screen will not come back on, I have tried Alt+F1 through Alt+F7. I've tried Ctrl+Alt+Del, Esc and nothing wakes up the monitor. Does anyone know how to fix this error?

Troubleshooting details for those interested in debugging:

I can still SSH into the box while the monitor is showing the error.

  1. I can still ssh into the box, here is the uname -a:

    Linux apollo 3.8.0-33-generic #48~precise1-Ubuntu SMP Thu Oct 24 
    16:28:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    
  2. Here is an exerpt from the dmesg error log:

    [509156.065626] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
    [509156.065709] [drm] capturing error event; look for more information in /debug/dri/0/i915_error_state
    [509156.070291] [drm:i915_write32] *ERROR* Unknown unclaimed register before writing to 220a8
    [509165.087235] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
    
  3. The computer was acting up before this event, where the screen would go dark, and I would have to press Alt+F2 and the monitor would refresh. This was getting worse and worse over the last 4 days.

  4. The temperature inside the house is never above 75 degrees.

  5. Running a sudo shutdown -r now and sudo halt does not reboot the computer.

  6. Holding down the power button reboots the computer, monitor comes back on and the problem eventually comes back after a while.

2

It was something to do with this Intel graphics problem. so I ran these commands:

sudo apt-get update
sudo apt-get dist-upgrade

Which prompted for a bunch of updates, prayer was part of the strategy:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-3.8.0-35 linux-headers-3.8.0-35-generic linux-image-3.8.0-35-generic
  linux-signed-image-3.8.0-35-generic
  The following packages will be upgraded:
  accountsservice apt apt-transport-https apt-utils avahi-autoipd avahi-daemon avahi-utils chromium-browser
  chromium-browser-l10n chromium-codecs-ffmpeg efibootmgr firefox firefox-locale-en fonts-opensymbol
  gnome-control-center gnome-control-center-data gnome-desktop3-data gnupg gpgv grub-common grub-efi
  grub-efi-amd64 grub-efi-amd64-bin grub2-common landscape-client-ui-install libaccountsservice0 libapt-inst1.4
  libapt-pkg4.12 libavahi-client3 libavahi-client3:i386 libavahi-common-data libavahi-common-data:i386
  libavahi-common3 libavahi-common3:i386 libavahi-core7 libavahi-glib1 libavahi-gobject0 libavahi-ui-gtk3-0
  libcurl3 libcurl3:i386 libcurl3-gnutls libcurl3-nss libdjvulibre-text libdjvulibre21 libgnome-control-center1
  libgnome-desktop-3-2 libjpeg-turbo-progs libjpeg-turbo8 libjpeg-turbo8:i386 libnss3 libnss3:i386 libnss3-1d
  libpixman-1-0 libpixman-1-0:i386 libpq5 libqt4-dbus libqt4-dbus:i386 libqt4-declarative libqt4-declarative:i386
  libqt4-designer libqt4-designer:i386 libqt4-help libqt4-network libqt4-network:i386 libqt4-opengl
  libqt4-opengl:i386 libqt4-qt3support libqt4-qt3support:i386 libqt4-script libqt4-script:i386 libqt4-scripttools
  libqt4-scripttools:i386 libqt4-sql libqt4-sql:i386 libqt4-sql-mysql libqt4-sql-mysql:i386 libqt4-sql-sqlite
  libqt4-svg libqt4-svg:i386 libqt4-test libqt4-test:i386 libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns
  libqt4-xmlpatterns:i386 libqtcore4 libqtcore4:i386 libqtgui4 libqtgui4:i386 libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-gnome
  libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-style-human
  libreoffice-style-tango libreoffice-writer libruby1.8 libsmbclient libwbclient0 linux-firmware
  linux-generic-lts-raring linux-headers-generic-lts-raring linux-image-generic-lts-raring linux-libc-dev
  linux-signed-generic-lts-raring linux-signed-image-generic-lts-raring php5 plasma-widget-networkmanagement
  python-uno qdbus rsyslog ruby1.8 samba-common samba-common-bin smbclient software-center thunderbird
  thunderbird-gnome-support thunderbird-locale-en thunderbird-locale-en-us uno-libs3 ure
129 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 354 MB of archives.
After this operation, 257 MB of additional disk space will be used.
Do you want to continue [Y/n]?

I did these updates and rebooted. And now the problem is fixed.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.