1

So i have a laptop that come with windows 8, like others i dislike it with passion, installed windows 7 over the top (i assumed it would atleast wipe the MBR properly but i dont think so anymore.

anyway this is my partition setup (according to the MBR Table, this is how i set it up, this is all correct:)My partition setup (MBR)

And so being the Ubuntu enthusiast I have a left over unallocated space at the end, I was going to install Ubuntu there with a dual boot, but parted, the partition manager in the Ubuntu setup reads that there is no compatible operating systems installed, hmm, so i searched around on google and on askubuntu, there's a lot of people having leftover GPT data.

On the Ubuntu live CD, I downloaded and launched fix parts, there was no warning message at the start, i was following this guide(http://www.rodsbooks.com/fixparts/), so at first i thought it may not be any GPT data

Until I got this up enter image description here

According to the guide I should have had a warning at the beginning, and being given the option to remove it.

I have created a system image of my windows install onto an external HDD

____________________________________________--

I also tried using GPT disk, it was very complicated, took me a while to even get it open, and then I count copy the backup of my partition table (parts.txt) out of the system rescue CD as I new it would delete when I powered it down.

So, how can I remove this GPT data so that parted will see my windows install? Or should I try and convert it all to GPT data?


As requested, here are the outputs to the following commands

The p menu option

Sudo fdisk -l /dev/sda

Parted print

gdisk doesnt seem to be in the package i have? or atleast the command is unknown enter image description here


This is the problem i am getting at in the first place, i wish to install ubuntu (dual booted with windows 7) onto that unallocated space at the end of my drive

But the ubuntu installer (i read it uses parted) simply does not recognise the windows partition

Eventually i was aiming to use the Borg bootloader,i was expecting the option "Install alongside windows 7" and thats what im trying to get, so i googled this problem, and lots of people had leftover GPT data, so now i have no idea where to go

2 Answers 2

0

That's very odd; FixParts is presenting conflicting information -- the reference to a 0xEE partition indicates a GPT disk, which should cause FixParts to exit; but it's not exiting. Could you please post what FixParts shows when you type p at its menu, and also the output of sudo fdisk -l /dev/sda, sudo gdisk -l /dev/sda, and sudo parted /dev/sda print? (You can cut-and-paste this rather than post a screen shot, but please add four spaces to the start of each line to keep it properly formatted.) This information will help me figure out what's going on. (Incidentally, I'm the author of FixParts.)

5
  • Original post updated, gdisk doesnt seem to be in the package i have?
    – kris2340k
    Commented Jan 5, 2014 at 17:46
  • Your partition table looks normal, aside from the FixParts warning about the 0xEE partition. Given the other information you posted, my guess is that the FixParts warning is a bug, so I'd ignore it. Could you please post a screen shot of the display that's causing you problems? It's not entirely clear what the program is telling you.
    – Rod Smith
    Commented Jan 6, 2014 at 1:01
  • Done, see last screenshot :/ getting no alongside install option.
    – kris2340k
    Commented Jan 6, 2014 at 20:34
  • Does anyone else have any clues as to why ubuntu cannot detect windows ?
    – kris2340k
    Commented Jan 8, 2014 at 23:54
  • Your final screen shot comes from before the partition manager; it just presents options for how to install. These options vary depending on a number of factors. The "Something Else" option is generally the most flexible, and is almost always present, so it can be a good way to get around such problems, although it does require more know-how or instruction to use. For the latter, see this question (or probably various others).
    – Rod Smith
    Commented Jan 10, 2014 at 17:51
0

PROBLEM SOLVED

So i was making links as to my desktop and laptop, they have very similar specs, identical graphics and almost identical gpu, BUT DIFFERENT Bios, this got me thinking

went into notebook bios, made a admin password (not needed) and changed the mode to disable AHCI, im assuiming its now IDE, somehow its now detecting it lool

by the way, to everyone out there, Windows remembers the mode and will not boot if you change it

in order to make windows forget which mode you have follow this guide

http://www.neowin.net/news/neowin-guide-how-to-change-from-ide-to-ahci-without-reinstalling-windows

I highly recommend you keep ACHI, im going to attempt to change it back after, ahci has many advantages

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .