7

I have HP Pavillion 14-n009tu laptop (i-5, 4GB) with Windows-8 OS installed on it. I am trying to install ubuntu 12.04 as a dual boot OS on Windows8. I have disabled fast boot and secure boot options also. I am facing following error while installing ubuntu 12.04:

grub-efi-amd64-signed failed to install into /target/. Without GRUB boot loader,
the installed system will not boot

I have created three partitions:

  1. 38GB-ext4- Root mounted
  2. 08GB-ext4- /home
  3. 10GB Swap area

Please guide me how to resolve this problem.

3

Hey Ramji Had the exact same problem. What fixed my problem was that i went through the steps again and made sure I was connected to the Internet the second time. go through the process again (don't partition again because the hard drive is still partitioned ) but this time chose the option to format the partitions so that you erase the information that was loaded before the installation failed. look at the comments here Why 12.04 Fails to install grub-efi to /target/? if you are still having problems follow this instructions http://www.everydaylinuxuser.com/2013/09/install-ubuntu-linux-alongside-windows.html

2

I solved the problem by creating a 200MB FAT32 partition in the beginning of the disk with the flags boot and esp. Creating a partition with this configuration was suggested by boot-repair tool after I got the error you mentioned and I tried to fix it using such tool.

I hope this helps! Good luck!

1

It is a bug. If you are installing using a pendrive, just modify the filename grub-efi-amd64-signed_1.9~ubuntu12.04.4+1.99-21ubuntu3.10_amd.deb in directory /pool/main/g/grub2-signed/ by adding 64 at the end before .deb. It works 100%.

https://bugs.launchpad.net/ubuntu/+bug/1633913

  • 1
    Not the case for 14.04 – raphael Apr 12 '16 at 15:11
0

I worked around this issue in Linux Mint 16 by running the following command before starting the install:

sudo dpkg --remove-architecture i386

It's probably caused by installing both 32- and 64-bit versions of all packages, in case only one of them exists (or maybe to support heterogeneous clusters that have both 32-bit and 64-bit CPUs). In the case of grub-efi-amd64 (which is part of grub-efi-amd64-signed), both versions exist, but they declare conflicts with each other so that they can't both be installed on the same system.

0

I had a same problem while installing Ubuntu 16.04 as well as while installing Mint.

The following steps fixed my problem:

  1. Install Ubuntu/Mint whichever you want (after the installation or in-between, you'll get this error).
  2. Start o. with live boot.
  3. Install boot repair.
  4. Follow steps in that.

That's it. Restart your PC and remember to remove the bootable medium you used.

-1

Disable the "Fast Boot" and "secure Boot" options in Boot Options menu. Select Legacy Boot. Restart the installation process. Create a boot partition >1MB during installation. This solved the issue for me in UBUNTU 16.04 LTS installation. Partitions created: /boot - 2048 MB swap - 10000 MB / - 50000 MB /home - 100000 MB

Marked remaining to be unused.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.