I have downloaded ubuntu desktop from the ubuntu website and name of the file is "ubuntu-12.04.3-desktop-i386.iso" as i am running from an intel machine.

That ISO file i have mounted using power iso and now i am trying to install from it using .exe file for ubuntu installer.

Still i am getting an error Cannot download the metalink and therefore the ISO.

If once i have already downloaded ISO,why would i need to download it again.

Please someone help me to solve this.

I have got something more.

If anyone can help me with this...... This time ubuntu installer tried to download the file ubuntu-12.04.3-desktop-amd64.iso

why this file on an intel machine


2 Answers 2


use the WUBI installer to install Ubuntu thru Windows 8 there is an excellent guide at this link http://apcmag.com/how-to-dual-boot-windows-8-and-linux.htm then get the WUBi installer at UBUNTU and double click and follow the instructions you might also consider AOMEI as partitioner and partition a separate drive for WUBI to install on

  • i tried to install it in a USB drive
    – user231811
    Jan 4, 2014 at 22:34

Here is what I found to be the problem: The installation executable is looking for an ISO file to install. Since the ISO is mounted you will need to copy that installation .exe into the same directory as your ISO file.

For example, if your ISO is in E:\ubuntu.iso and if your mounted ISO file is in D:\ your installer should be D:\wubi.exe

Then you will need to copy wubi.exe to E:\wubi.exe, placing it next to the ubuntu.iso file. Unmount your ISO image, and then run wubi.exe as Administrator. This should allow you to install.

Pictures can be found here: http://tech.nickballesteros.com/2011/05/ubuntu-error-cannot-download-metalink.html

  • tried got the same error
    – user231811
    Jan 4, 2014 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.